summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeeweep2019-10-02 03:10:50 +0800
committerpeeweep2019-10-02 03:10:50 +0800
commitdfba72bc1a5b036f6bcd2004e18384f502093d9d (patch)
tree0847b0ee668e6be995d0742aef49b8e4c09903e1
downloadaur-dfba72bc1a5b036f6bcd2004e18384f502093d9d.tar.gz
Init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD31
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7492f110129
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = analyzemft-git
+ pkgdesc = Fully parse the MFT file from an NTFS filesystem
+ pkgver = 20180318.64c71d7
+ pkgrel = 1
+ url = https://github.com/dkovar/analyzeMFT
+ arch = any
+ license = CPL
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ source = analyzeMFT::git+https://github.com/dkovar/analyzeMFT.git
+ sha256sums = SKIP
+
+pkgname = analyzemft-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e895b46cb5ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+analyzeMFT/
+pkg/
+src/
+*.log
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d1b3880f3f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: peeweep <peeweep at 0x0 dot ee>
+
+pkgname=analyzemft-git
+_pkgname=analyzeMFT
+pkgver=20180318.64c71d7
+pkgrel=1
+pkgdesc='Fully parse the MFT file from an NTFS filesystem'
+arch=('any')
+url="https://github.com/dkovar/analyzeMFT"
+license=('CPL')
+depends=('python2')
+makedepends=('git' 'python2-setuptools')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: