summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAvery2015-06-08 19:44:49 -0500
committerAvery2015-06-08 19:44:49 -0500
commitdff657803c63be40c92f27bb38e29b485d838771 (patch)
tree767e6424a2bba01c351a46104aafeed2d93ab20b
downloadaur-dff657803c63be40c92f27bb38e29b485d838771.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..962c06e70a37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hal-flash
+ pkgdesc = A libhal stub library forwarding to UDisks2 for flash to play DRM content
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/cshorler/hal-flash
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = autoconf>=2.60
+ makedepends = pkgconfig
+ makedepends = git
+ depends = udisks2
+ depends = dbus
+ provides = hal=0.5.15
+ conflicts = hal
+ source = https://github.com/cshorler/hal-flash/archive/v0.3.0.tar.gz
+ md5sums = 034943dde1c3e18266e396c7552542b4
+
+pkgname = hal-flash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..777428b5f2d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Freonmonkey <freonmonkey at gmail dot com>
+#
+# This project provides a stub libhal that uses UDisks and meets the needs
+# for playing Flash DRM content without a full HAL installation and daemon.
+
+pkgname=hal-flash
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A libhal stub library forwarding to UDisks2 for flash to play DRM content"
+arch=('i686' 'x86_64')
+url="https://github.com/cshorler/hal-flash"
+license=('GPL2')
+groups=()
+depends=('udisks2' 'dbus')
+makedepends=('autoconf>=2.60' 'pkgconfig' 'git')
+provides=('hal=0.5.15')
+conflicts=('hal')
+source=("https://github.com/cshorler/hal-flash/archive/v0.3.0.tar.gz")
+md5sums=('034943dde1c3e18266e396c7552542b4')
+
+prepare() {
+ mv "$srcdir/$pkgname-$pkgver" "$srcdir/$pkgname"
+
+ cd "$srcdir/$pkgname"
+
+ msg2 "Running autoreconf..."
+ autoreconf -i
+ msg2 "Running configure..."
+ ./configure --prefix=/usr --enable-static=no
+
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ # Install built files into the package
+ cd "$srcdir/$pkgname"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+
+ # Skip copying COPYING to LICENSE since it's just GPL2
+}
+