summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroberon20072016-01-09 19:48:55 +0100
committeroberon20072016-01-09 19:48:55 +0100
commite011f7458af4fd26e8bb298cb4fef1dac3fe945c (patch)
treefe295b0ff071f373e80fd2e833502eeb4d8835f5
downloadaur-e011f7458af4fd26e8bb298cb4fef1dac3fe945c.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rw-r--r--alternating-layouts.install14
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77318f823dc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 18:43:33 UTC 2016
+pkgbase = alternating-layouts-git
+ pkgdesc = Alternating split directions for the i3-wm
+ pkgver = r20.179edd6
+ pkgrel = 1
+ url = github.com/olemartinorg/i3-alternating-layout
+ install = alternating-layouts.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = i3-wm
+ depends = python-i3-git
+ depends = xorg-utils
+ source = git://github.com/olemartinorg/i3-alternating-layout
+ md5sums = SKIP
+
+pkgname = alternating-layouts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7204e20780b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
+
+pkgname=alternating-layouts-git
+pkgver=r20.179edd6
+pkgrel=1
+pkgdesc="Alternating split directions for the i3-wm"
+_repo=i3-alternating-layout
+url="github.com/olemartinorg/$_repo"
+arch=('any')
+license=('MIT')
+depends=('i3-wm'
+ 'python-i3-git'
+ 'xorg-utils')
+conflicts=('alternating-layouts')
+makedepends=('git')
+install=alternating-layouts.install
+source=("git://$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_repo
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_repo
+ install -Dm 755 alternating_layouts.py $pkgdir/usr/bin/alternating_layouts.py
+}
diff --git a/alternating-layouts.install b/alternating-layouts.install
new file mode 100644
index 000000000000..87b86d3d5c44
--- /dev/null
+++ b/alternating-layouts.install
@@ -0,0 +1,14 @@
+post_install() {
+
+ msg() {
+ ALL_OFF="\e[1;0m"
+ BOLD="\e[1;1m"
+ GREEN="${BOLD}\e[1;32m"
+ local mesg=$1; shift
+ printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}\n" "$@" >&2
+ }
+ echo ""
+ msg "autostart alternating-layouts in your ~/.i3/config with"
+ msg "'exec --no-startup-id python alternating_layouts.py'"
+ echo ""
+}