summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2020-05-09 15:48:06 +0200
committerEmmanuel Gil Peyrot2020-05-09 15:48:06 +0200
commite022deba440ddec723d5f457068be7469fc82de2 (patch)
tree203adbc2a20b624be2354436e0132ad5091c9411
parentdf3cb6e1685f68dea76f6d34c00e021ef4e20f22 (diff)
downloadaur-e022deba440ddec723d5f457068be7469fc82de2.tar.gz
Replace pandoc with python-sphinx and python-sphinx_rtd_theme.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 943f357155df..3c1b7aeccca9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Sep 4 14:22:47 UTC 2018
pkgbase = biboumi-git
pkgdesc = XMPP gateway to IRC
- pkgver = 8.2.r74.gcd20177
+ pkgver = 8.5.r187.g0479bd0
pkgrel = 1
url = https://biboumi.louiz.org/
install = biboumi.install
@@ -13,7 +11,8 @@ pkgbase = biboumi-git
license = ZLIB
makedepends = git
makedepends = cmake
- makedepends = pandoc
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
depends = expat
depends = libidn
depends = udns
diff --git a/PKGBUILD b/PKGBUILD
index 08c7b7095ec9..79db3f6ca899 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=biboumi
pkgname="$_pkgname-git"
-pkgver=8.2.r74.gcd20177
+pkgver=8.5.r187.g0479bd0
pkgrel=1
pkgdesc="XMPP gateway to IRC"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://biboumi.louiz.org/"
license=('ZLIB')
depends=('expat' 'libidn' 'udns' 'botan' 'sqlite' 'postgresql-libs')
-makedepends=('git' 'cmake' 'pandoc')
+makedepends=('git' 'cmake' 'python-sphinx' 'python-sphinx_rtd_theme')
backup=("etc/$_pkgname/$_pkgname.cfg")
install="$_pkgname.install"
source=("$_pkgname::git+https://lab.louiz.org/louiz/biboumi.git"
@@ -38,17 +38,21 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DSERVICE_USER=biboumi \
- -DSERVICE_GROUP=jabber
- make biboumi
+ -DSERVICE_GROUP=jabber \
+ -Wno-dev
+ make
+ make doc
}
package() {
cd $_pkgname/build
make DESTDIR="$pkgdir/" install
+ install -dm755 "$pkgdir"/usr/share/doc/$_pkgname/
+ cp -r html "$pkgdir"/usr/share/doc/$_pkgname/
+
cd ..
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
- install -dm755 "$pkgdir"/usr/share/doc/$_pkgname/
install -Dm644 doc/*.rst "$pkgdir"/usr/share/doc/$_pkgname/
install -Dm644 conf/biboumi.cfg "$pkgdir"/etc/$_pkgname/$_pkgname.cfg