summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormarco442017-02-17 16:13:53 +0100
committermarco442017-02-17 16:13:53 +0100
commite0336a123d66ddcc9fdc1f6b2ce4f6ac81af75b0 (patch)
treed466d40862645d6df878578c7734d7b39f83d501
downloadaur-e0336a123d66ddcc9fdc1f6b2ce4f6ac81af75b0.tar.gz
First commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--hypopg-git.install3
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11dd9ef893ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hypopg-git
+ pkgdesc = postgresql background worker to capture data
+ pkgver = b78049e
+ pkgrel = 1
+ url = https://github.com/dalibo/hypopg
+ install = hypopg-git.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = BSD
+ makedepends = git
+ depends = postgresql
+ options = !emptydirs
+ options = !libtool
+ source = git://github.com/dalibo/hypopg.git
+ md5sums = SKIP
+
+pkgname = hypopg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26cfb2d46139
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Marco44 (Marc Cousin) <cousinmarc at gmail dot com>
+pkgname=hypopg-git
+_gitname=hypopg
+pkgver=b78049e
+pkgrel=1
+pkgdesc="postgresql background worker to capture data"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/dalibo/hypopg"
+license=('BSD')
+depends=('postgresql')
+builddepends=()
+makedepends=(git)
+options=(!emptydirs !libtool)
+source=('git://github.com/dalibo/hypopg.git')
+md5sums=('SKIP')
+install='hypopg-git.install'
+
+pkgver() {
+ cd $_gitname
+ tag=`git tag | grep REL | tail -1`
+ commit=`git log --format="%h" -n 1`
+ echo "$tag_$commit"
+}
+
+build() {
+ local _gitdir=$srcdir/$_gitname
+ cd $_gitdir
+ git clean -dfx
+ git reset --hard
+ make
+}
+
+package() {
+ cd $srcdir/$_gitname
+ make DESTDIR=$pkgdir install
+}
diff --git a/hypopg-git.install b/hypopg-git.install
new file mode 100644
index 000000000000..7bba0191af3a
--- /dev/null
+++ b/hypopg-git.install
@@ -0,0 +1,3 @@
+post_install(){
+ echo "http://powa.readthedocs.io/en/latest/stats_extensions/hypopg.html"
+}