summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-06 03:47:39 +0200
committersL1pKn072021-10-06 03:47:39 +0200
commite041c295fad014a2a46bff2d045b878957f05fd7 (patch)
tree6ab52bd95aac4fd885d418fea6f8f6eec0a9acb0
parent3207bcd60e91d47107c45460e3746ed86286775d (diff)
downloadaur-e041c295fad014a2a46bff2d045b878957f05fd7.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 184988c02d15..3f8bf1d810f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = avs2yuv-git
pkgdesc = A simple tool that can execute avisynth scripts. (GIT version)
- pkgver = r20.7aa19f9
+ pkgver = 0.30.6.g631e97c
pkgrel = 1
url = https://github.com/DJATOM/avs2yuv
arch = x86_64
- license = LGPL
+ license = GPL
makedepends = git
+ makedepends = cmake
depends = avisynthplus
provides = avs2yuv
conflicts = av2yuv
@@ -13,4 +14,3 @@ pkgbase = avs2yuv-git
sha256sums = SKIP
pkgname = avs2yuv-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e8590c00f9b0..41ea36c91e0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=avs2yuv-git
-pkgver=r20.7aa19f9
+pkgver=0.30.6.g631e97c
pkgrel=1
pkgdesc="A simple tool that can execute avisynth scripts. (GIT version)"
arch=('x86_64')
url='https://github.com/DJATOM/avs2yuv'
-license=('LGPL')
+license=('GPL')
depends=('avisynthplus')
-makedepends=('git')
+makedepends=('git'
+ 'cmake'
+ )
provides=('avs2yuv')
conflicts=('av2yuv')
source=('git+https://github.com/DJATOM/avs2yuv.git')
@@ -16,15 +18,24 @@ sha256sums=('SKIP')
pkgver() {
cd avs2yuv
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-# echo "$(git describe --long --tags | tr - .)"
+# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
}
build() {
- make -C avs2yuv
+ cd build
+
+ cmake ../avs2yuv \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=usr
+
+ make
}
package(){
- install -d "${pkgdir}/usr/bin"
- make -C avs2yuv PREFIX="${pkgdir}/usr" install
+ make -C build PREFIX="${pkgdir}/usr" install
}