summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2022-08-18 12:58:04 +0200
committerOleksandr Natalenko2022-08-18 12:58:04 +0200
commite05f3367ab793fc7d2508ef654a2341849320d74 (patch)
treeaa332c85a8971ab457aa1376712eb5d7dba6912d
parent82298aba9794b2d10b6452999818047ec6d31c06 (diff)
downloadaur-e05f3367ab793fc7d2508ef654a2341849320d74.tar.gz
support clang
Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--meson.build36
3 files changed, 36 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8afeb2ca3750..0cc622aeae3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = 7-zip
pkgdesc = File archiver with a high compression ratio
pkgver = 22.01
- pkgrel = 1
- url = https://www.7-zip.org
+ pkgrel = 2
+ url = https://7-zip.org
arch = x86_64
license = LGPL
license = BSD
@@ -12,6 +12,6 @@ pkgbase = 7-zip
source = https://7-zip.org/a/7z2201-src.tar.xz
source = meson.build
sha256sums = 393098730c70042392af808917e765945dc2437dee7aae3cfcc4966eb920fbc5
- sha256sums = 9ed64c321a4425a8874c56aa0c64132829001be5ad8fdda28426254b723829a1
+ sha256sums = 8b47dd17a5094b487dc343f00113db3c08e94e929a494fbd582bd8c067e539e3
pkgname = 7-zip
diff --git a/PKGBUILD b/PKGBUILD
index 10bb7694968e..007d1f7ba7f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=7-zip
pkgver=22.01
-pkgrel=1
+pkgrel=2
pkgdesc="File archiver with a high compression ratio"
-url="https://www.7-zip.org"
+url=https://7-zip.org
license=('LGPL' 'BSD' 'custom:unRAR')
arch=(x86_64)
makedepends=(uasm meson)
-source=(https://7-zip.org/a/7z2201-src.tar.xz
+source=(${url}/a/7z2201-src.tar.xz
meson.build)
sha256sums=('393098730c70042392af808917e765945dc2437dee7aae3cfcc4966eb920fbc5'
- '9ed64c321a4425a8874c56aa0c64132829001be5ad8fdda28426254b723829a1')
+ '8b47dd17a5094b487dc343f00113db3c08e94e929a494fbd582bd8c067e539e3')
build() {
arch-meson . build
diff --git a/meson.build b/meson.build
index 9f48e66ccbd1..14d1ab173900 100644
--- a/meson.build
+++ b/meson.build
@@ -360,20 +360,13 @@ add_project_arguments(
'-D_7ZIP_ASM',
'-Waddress',
'-Waddress-of-packed-member',
- '-Waggressive-loop-optimizations',
'-Wattributes',
- '-Wbool-compare',
'-Wbool-operation',
'-Wcast-align',
- '-Wcast-align=strict',
'-Wcomment',
'-Wconversion',
'-Wdangling-else',
'-Wdiv-by-zero',
- '-Wduplicated-branches',
- '-Wduplicated-cond',
- '-Wformat-contains-nul',
- '-Wimplicit-fallthrough=5',
'-Winit-self',
'-Wint-in-bool-context',
'-Wint-to-pointer-cast',
@@ -386,6 +379,35 @@ add_project_arguments(
],
)
+if cpp.get_id() == 'gcc'
+ add_project_arguments(
+ [
+ '-Waggressive-loop-optimizations',
+ '-Wbool-compare',
+ '-Wcast-align=strict',
+ '-Wduplicated-branches',
+ '-Wduplicated-cond',
+ '-Wformat-contains-nul',
+ '-Wimplicit-fallthrough=5',
+ ],
+ language: [
+ 'c',
+ 'cpp',
+ ],
+ )
+elif cpp.get_id() == 'clang'
+ add_project_arguments(
+ [
+ '-Wno-sign-conversion',
+ '-Wno-unused-but-set-variable',
+ ],
+ language: [
+ 'c',
+ 'cpp',
+ ],
+ )
+endif
+
add_project_arguments(
[
'-Wno-non-virtual-dtor',