summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-07-24 13:10:27 +0300
committerCaleb Maclennan2021-07-24 13:10:27 +0300
commite082c7767736c8d4bec1fb22e5186962ea67c679 (patch)
tree9bbdd231dac9c7159a81bba909df278d840a7ab5
parent0960b454c98f4f4ba7a3665fa50bfb6ecca89f3a (diff)
downloadaur-e082c7767736c8d4bec1fb22e5186962ea67c679.tar.gz
upgpkg: kindlegen 2.9-6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0327f2a2bfe..a1c4517d1f4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = kindlegen
- pkgdesc = A command line tool used to build eBooks that can be sold through Amazon's Kindle platform.
+ pkgdesc = cli tool to build eBooks that can be used on Amazon’s Kindle platform (binary)
pkgver = 2.9
- pkgrel = 5
+ pkgrel = 6
url = https://www.amazon.com/gp/feature.html?ie=UTF8&docId=1000765211
arch = i686
arch = x86_64
license = custom
- source = https://archive.org/download/kindlegen/kindlegen
- sha256sums = b8b0f0ab83e74070119066bf4f3c56267e5ee43d2c2bac7091bb447e9f461a69
+ source = https://archive.org/download/kindlegen2.9/kindlegen_linux_2.6_i386_v2_9.tar.gz
+ md5sums = 21aef3c8846946203e178c83a37beba1
+ sha256sums = 9828db5a2c8970d487ada2caa91a3b6403210d5d183a7e3849b1b206ff042296
pkgname = kindlegen
-
diff --git a/PKGBUILD b/PKGBUILD
index 7fe552937123..57535a5d9bef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: AUR[flyingpig]
# Contributor: Valentin-Costel Haloiu <vially.ichb@gmail.com>
# Contributor: Eugene Yunak <e.yunak@gmail.com>
# Contributor: Pellegrino Prevete <pellegrinoprevete@gmail.com>
pkgname=kindlegen
pkgver=2.9
-pkgrel=5
-pkgdesc="A command line tool used to build eBooks that can be sold through Amazon's Kindle platform."
-arch=('i686' 'x86_64')
+pkgrel=6
+pkgdesc='cli tool to build eBooks that can be used on Amazon’s Kindle platform (binary)'
+arch=(i686 x86_64)
url="https://www.amazon.com/gp/feature.html?ie=UTF8&docId=1000765211"
license=(custom)
-source=("https://archive.org/download/kindlegen/kindlegen")
-sha256sums=('b8b0f0ab83e74070119066bf4f3c56267e5ee43d2c2bac7091bb447e9f461a69')
+source=("https://archive.org/download/$pkgname$pkgver/${pkgname}_linux_2.6_i386_v${pkgver/./_}.tar.gz")
+md5sums=('21aef3c8846946203e178c83a37beba1')
+sha256sums=('9828db5a2c8970d487ada2caa91a3b6403210d5d183a7e3849b1b206ff042296')
package() {
- install -D -m755 $srcdir/kindlegen $pkgdir/usr/bin/kindlegen
-
+ install -Dm0755 -t "$pkgdir/usr/bin/" kindlegen
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" EULA.txt "KindleGen Legal Notices 2013-02-19 Linux.txt"
+ install -Dm0644 -t "$pkgdir/usr/share/doc/$pkgname/" manual.html docs/english/*
}