summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2020-06-20 11:27:23 +0300
committerIvan Shapovalov2020-06-20 11:27:23 +0300
commite0bda2bdc7314c8f6710dba1b986acbe39846f35 (patch)
treeea3f3924523019d3a02abb815242c872fa9acb05
parent45068ef82307aad3f7a89a046e688b0a64fa9f7a (diff)
downloadaur-e0bda2bdc7314c8f6710dba1b986acbe39846f35.tar.gz
Bump, update patch, depend on libimobiledevice (non-git)
-rw-r--r--.SRCINFO4
-rw-r--r--0001-configure.ac-check-for-pthreads.patch10
-rw-r--r--PKGBUILD6
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c660ad3d902..3f5cbf46507d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,14 +9,14 @@ pkgbase = idevicerestore-git
license = LGPL3
makedepends = git
depends = libirecovery-git
- depends = libimobiledevice-git
+ depends = libimobiledevice
depends = libzip
depends = openssl
depends = curl
source = git+https://github.com/libimobiledevice/idevicerestore
source = 0001-configure.ac-check-for-pthreads.patch
sha256sums = SKIP
- sha256sums = c259a9f977de42fbfde75ad0c9a4d813b7d39bf217ee416902409403cd6d7931
+ sha256sums = d7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15
pkgname = idevicerestore-git
diff --git a/0001-configure.ac-check-for-pthreads.patch b/0001-configure.ac-check-for-pthreads.patch
index de2f7c5120e9..cadb4117f9e8 100644
--- a/0001-configure.ac-check-for-pthreads.patch
+++ b/0001-configure.ac-check-for-pthreads.patch
@@ -1,4 +1,4 @@
-From 162a079123f81f14287dcd6d3e5b4488dc6981ee Mon Sep 17 00:00:00 2001
+From 66dc1fa84fbe65f1008255d2b1d9bced9cf9dce6 Mon Sep 17 00:00:00 2001
From: Ivan Shapovalov <intelfx100@gmail.com>
Date: Fri, 25 Sep 2015 23:37:27 +0300
Subject: [PATCH] configure.ac: check for pthreads
@@ -9,7 +9,7 @@ Fixes building at least on Arch.
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
-index d36cc67..950ef02 100644
+index 1db709a..c722910 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ AM_PROG_CC_C_O
@@ -17,9 +17,9 @@ index d36cc67..950ef02 100644
# Checks for libraries.
+AC_SEARCH_LIBS([pthread_create], [pthread])
- PKG_CHECK_MODULES(libirecovery, libirecovery >= $LIBIRECOVERY_VERSION)
+ PKG_CHECK_MODULES(libirecovery, libirecovery-1.0 >= $LIBIRECOVERY_VERSION)
PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= $LIBIMOBILEDEVICE_VERSION)
- PKG_CHECK_MODULES(libplist, libplist >= $LIBPLIST_VERSION)
+ PKG_CHECK_MODULES(libplist, libplist-2.0 >= $LIBPLIST_VERSION)
--
-2.6.2
+2.27.0
diff --git a/PKGBUILD b/PKGBUILD
index 2eb3d5974db8..4ee251ed1cce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
pkgname=idevicerestore-git
epoch=1
-pkgver=r663.0b4810f
+pkgver=r705.21a242e
pkgrel=1
pkgdesc="Restore/upgrade firmware of iOS devices"
arch=('i686' 'x86_64')
url="http://www.libimobiledevice.org"
license=('LGPL3')
-depends=('libirecovery-git' 'libimobiledevice-git' 'libzip' 'openssl' 'curl')
+depends=('libirecovery-git' 'libimobiledevice' 'libzip' 'openssl' 'curl')
makedepends=('git')
source=("git+https://github.com/libimobiledevice/idevicerestore"
"0001-configure.ac-check-for-pthreads.patch")
sha256sums=('SKIP'
- 'c259a9f977de42fbfde75ad0c9a4d813b7d39bf217ee416902409403cd6d7931')
+ 'd7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15')
pkgver() {
cd idevicerestore