summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhys Perry2020-06-10 10:28:15 +0100
committerRhys Perry2020-06-10 10:28:15 +0100
commite0d149a4420e47effab48f5bf31c07c3182264e9 (patch)
tree949d5e1da9e77ffdc1dd80ba82139234f8af8f54
parent40ef1412204cb67a4fd647226db088e6a5b8427b (diff)
downloadaur-e0d149a4420e47effab48f5bf31c07c3182264e9.tar.gz
Fix everything
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD42
-rw-r--r--fathom.db0
3 files changed, 26 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98d57ee509cb..69481209bb0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = fathom-git
- pkgdesc = Fathom - simple website analytics (Community Edition)
- pkgver = v1.2.1.r43.gb278944
- pkgrel = 1
+ pkgdesc = Fathom Lite. Simple, privacy-focused website analytics.
+ pkgver = 1.2.1.r55.g69baac5
+ pkgrel = 2
url = https://github.com/usefathom/fathom
arch = any
license = MIT
- makedepends = git
- makedepends = go-pie
+ makedepends = go
makedepends = npm
provides = fathom
conflicts = fathom
diff --git a/PKGBUILD b/PKGBUILD
index c3f7df961599..03a43dae00b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,42 @@
pkgname="fathom-git"
-pkgrel=1
-pkgver="v1.2.1.r43.gb278944"
-pkgdesc="Fathom - simple website analytics (Community Edition)"
+pkgrel=2
+pkgver=1.2.1.r55.g69baac5
+pkgdesc="Fathom Lite. Simple, privacy-focused website analytics."
url="https://github.com/usefathom/fathom"
license=("MIT")
arch=("any")
provides=("fathom")
conflicts=("fathom")
-
-makedepends=("git" "go-pie" "npm")
-
+makedepends=("go" "npm")
source=("git+https://github.com/usefathom/fathom.git")
md5sums=("SKIP")
_gitname="fathom"
-blddir="$(pwd)"/"build"
pkgver() {
- cd "$_gitname"
+ cd "$srcdir"/"$_gitname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+
build(){
- cp -r "$srcdir" "$blddir"
- cd "$blddir"
-
- mkdir -p gopath/src/github.com/usefathom
- ln -rTsf "$_gitname" gopath/src/github.com/usefathom/fathom
+ cd "$srcdir"
- export GOPATH="$blddir"/gopath
- cd "$_gitname"
- make build
+ rm -rf gopath
+ mkdir -p "gopath/src/github.com/usefathom"
+ mv "$_gitname" "gopath/src/github.com/usefathom/"
+
+ cd "gopath/src/github.com/usefathom/fathom"
+ export GOPATH="$srcdir"/gopath/
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ pwd
+ make GOFLAGS="-buildmode=pie" build
}
package(){
- cd "$blddir"/"$_gitname"
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ cd "$srcdir"/gopath/src/github.com/usefathom/fathom
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/fathom/LICENSE
install -Dm755 fathom "$pkgdir"/usr/bin/fathom
- rm -rf "$blddir"
-} \ No newline at end of file
+}
diff --git a/fathom.db b/fathom.db
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/fathom.db
+++ /dev/null