summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyszard Knop2017-09-07 17:49:57 +0200
committerRyszard Knop2017-09-07 17:49:57 +0200
commite0e264aa249f16c5b404d05e2061bbfb45ed8a43 (patch)
tree5b586fc79e44d006f844a568ae041f389dab59ee
parenta77542f2481582de534cc9968c95400e8ed6d3b2 (diff)
downloadaur-e0e264aa249f16c5b404d05e2061bbfb45ed8a43.tar.gz
Updated to the latest download link, PKGBUILD now matches all the other Substance pkgs
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--substance-player11
-rw-r--r--substance-player-2017.desktop10
-rw-r--r--substance-player-icon.png (renamed from substance-player-icon-2017.png)bin5038 -> 5038 bytes
-rw-r--r--substance-player.desktop12
6 files changed, 51 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffe9861e7892..1c4e2412d768 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Wed Aug 2 06:12:35 UTC 2017
pkgbase = substance-player
- pkgdesc = Node-based, non-destructive PBR material player
+ pkgdesc = PBR material preview, visualization and tweaking software.
pkgver = 2017.1.0
- pkgrel = 1
- url = https://www.allegorithmic.com/
+ pkgrel = 2
+ url = https://www.allegorithmic.com/products/substance-player
arch = x86_64
license = custom
depends = fontconfig
@@ -13,12 +11,14 @@ pkgbase = substance-player
depends = hicolor-icon-theme
depends = libtiff4
options = !strip
- source = https://alg-releases.s3.amazonaws.com/public_releases/substance-player/2017.x/Substance_Player-2017.1.0-305-linux-x64-standard-full.rpm
- source = substance-player-icon-2017.png
- source = substance-player-2017.desktop
+ source = https://download.allegorithmic.com/substance-player/2017.x/Substance_Player-2017.1.0-305-linux-x64-standard-full.rpm
+ source = substance-player-icon.png
+ source = substance-player.desktop
+ source = substance-player
sha256sums = 90ed4e491e3fa18f14e112b3a7bfb2d46ecd59833bc2de824b2dcd085946bb75
sha256sums = 87d2e879c24a26e63334614b9f1c5d24bfb2eb2b606762b63ce5a2fe6a54345e
- sha256sums = 23dcde3924b5dca3aa114ff6570d29c68e150e023fd095e889d0bd3aecbd0a7e
+ sha256sums = 4c95e98abcf740f92cf65ba64ce142a8bda42798d632a06e2e4c3cb871a37626
+ sha256sums = f024998986230fe480ea77c62c655e0e468e0b3664dbc0120d865311db19944e
pkgname = substance-player
diff --git a/PKGBUILD b/PKGBUILD
index 5c398354517f..302e644ab504 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,34 @@
+# Maintainer: Oscar Morante <spacepluk@gmail.com>
+# Co-maintainer: Dragoon Aethis <dragoon@dragonic.eu>
pkgname=substance-player
-_pkgname=substance-player
pkgver=2017.1.0
-_pkgver=2017
-pkgrel=1
-pkgdesc="Node-based, non-destructive PBR material player"
+pkgrel=2
+pkgdesc="PBR material preview, visualization and tweaking software."
arch=('x86_64')
-url='https://www.allegorithmic.com/'
+url='https://www.allegorithmic.com/products/substance-player'
license=('custom')
depends=('fontconfig' 'gcc-libs-multilib' 'glu' 'hicolor-icon-theme' 'libtiff4')
options=('!strip')
-source=( "https://alg-releases.s3.amazonaws.com/public_releases/${_pkgname}/2017.x/Substance_Player-${pkgver}-305-linux-x64-standard-full.rpm"
- "substance-player-icon-${_pkgver}.png"
- "substance-player-${_pkgver}.desktop")
+source=('https://download.allegorithmic.com/substance-player/2017.x/Substance_Player-2017.1.0-305-linux-x64-standard-full.rpm'
+ 'substance-player-icon.png'
+ 'substance-player.desktop'
+ 'substance-player')
noextract=()
sha256sums=('90ed4e491e3fa18f14e112b3a7bfb2d46ecd59833bc2de824b2dcd085946bb75'
'87d2e879c24a26e63334614b9f1c5d24bfb2eb2b606762b63ce5a2fe6a54345e'
- '23dcde3924b5dca3aa114ff6570d29c68e150e023fd095e889d0bd3aecbd0a7e')
+ '4c95e98abcf740f92cf65ba64ce142a8bda42798d632a06e2e4c3cb871a37626'
+ 'f024998986230fe480ea77c62c655e0e468e0b3664dbc0120d865311db19944e')
validpgpkeys=()
package() {
- mkdir -p "${pkgdir}/opt/Allegorithmic"
- mv "${srcdir}/opt/Allegorithmic/Substance_Player" "${pkgdir}/opt/Allegorithmic"
- mv "${pkgdir}/opt/Allegorithmic/Substance_Player" "${pkgdir}/opt/Allegorithmic/Substance_Player_${_pkgver}"
+ mkdir -p ${pkgdir}/opt/Allegorithmic
+ mv ${srcdir}/opt/Allegorithmic/Substance_Player ${pkgdir}/opt/Allegorithmic
- install -Dm644 "${pkgdir}/opt/Allegorithmic/Substance_Player_${_pkgver}/eula.txt" \
- "${pkgdir}/usr/share/licenses/${_pkgname}/eula.txt"
- rm "${pkgdir}/opt/Allegorithmic/Substance_Player_${_pkgver}/eula.txt"
+ install -Dm644 ${pkgdir}/opt/Allegorithmic/Substance_Player/eula.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/eula.txt
+ rm ${pkgdir}/opt/Allegorithmic/Substance_Player/eula.txt
- install -Dm644 -t "${pkgdir}/usr/share/applications" \
- "${srcdir}/substance-player-${_pkgver}.desktop"
- install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" \
- "${srcdir}/substance-player-icon-${_pkgver}.png"
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/substance-player.desktop"
+ install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" "${srcdir}/substance-player-icon.png"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/substance-player"
}
-
diff --git a/substance-player b/substance-player
new file mode 100644
index 000000000000..cd91084600a5
--- /dev/null
+++ b/substance-player
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+# If the interface is too small/big, uncomment the following line and tweak the value accordingly.
+#export QT_SCALE_FACTOR=0.75
+
+# If you're using a Nvidia Optimus setup, uncomment the line below and comment the final line to
+# always use the Nvidia GPU for this software (which is often too heavy for integrated GPUs).
+#exec primusrun /opt/Allegorithmic/Substance_Player/Substance\ Player "$@"
+
+exec /opt/Allegorithmic/Substance_Player/Substance\ Player "$@"
+
diff --git a/substance-player-2017.desktop b/substance-player-2017.desktop
deleted file mode 100644
index 1612bfae1551..000000000000
--- a/substance-player-2017.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=2017.1.0
-Name=Substance Player 2017
-Description=Substance Player is a 3D painting software allowing you to texture, render and share your work.
-Exec="/opt/Allegorithmic/Substance_Player_2017/Substance Player"
-Icon=substance-player-icon-2017
-Terminal=false
-Type=Application
-StartupNotify=true
-Categories=Graphics;Application;
diff --git a/substance-player-icon-2017.png b/substance-player-icon.png
index 97194926a997..97194926a997 100644
--- a/substance-player-icon-2017.png
+++ b/substance-player-icon.png
Binary files differ
diff --git a/substance-player.desktop b/substance-player.desktop
new file mode 100644
index 000000000000..847e61490343
--- /dev/null
+++ b/substance-player.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Substance Player
+GenericName=PBR Material Preview/Tweaking Software
+Description=PBR material preview, visualization and tweaking software
+Exec=/usr/bin/substance-player
+Icon=substance-player-icon
+Version=2017.1.0
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Utility;Graphics
+MimeType=application/x.allegorithmic.package;application/x.allegorithmic.substance