summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Brost2023-07-08 11:57:16 +0200
committerJulian Brost2023-07-08 12:01:28 +0200
commite0ed794bc82451efe4519d2b862d98182ba04db6 (patch)
tree086935530e301f90fbec1c7cb2d0adbc9a208753
parent4fc69d9208f10d0c7a5a84719913ed53aa2b623a (diff)
downloadaur-e0ed794bc82451efe4519d2b862d98182ba04db6.tar.gz
remove example service file and install script
Installing the service file to /usr/lib/systemd/system made little sense anyways as it can't be used without editing it anyways. Also, by far not the only way to run Trac, I trust users to be able to pick their preferred method and implement it for their setup themselves. The install script became obsolete as it basically just said that the installed service file isn't usable in the default state.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
-rw-r--r--trac.install11
-rw-r--r--tracd.service11
4 files changed, 2 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf9b62f4df21..18506dcb415e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,6 @@ pkgbase = trac
pkgver = 1.4.3
pkgrel = 1
url = http://trac.edgewall.org/
- install = trac.install
arch = any
license = BSD
makedepends = python2-babel
@@ -16,8 +15,6 @@ pkgbase = trac
optdepends = python2-babel: localization support
optdepends = python2-pytz: complete list of time zones
source = https://download.edgewall.org/trac/Trac-1.4.3.tar.gz
- source = tracd.service
sha256sums = c93ceed9abee6e3c7789f469862e82a3b9bf3405be73aae3221b5c259e062d21
- sha256sums = 3f050f1c9367b1b28e18a6ff0088f991676a9fbba3f5177859ce4db64f95ca42
pkgname = trac
diff --git a/PKGBUILD b/PKGBUILD
index 2fd3b9176d2a..4dfe9095c96e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,11 +16,8 @@ optdepends=('python2-psycopg2: PostgreSQL database support'
'python2-docutils: reStructuredText support'
'python2-babel: localization support'
'python2-pytz: complete list of time zones')
-install=trac.install
-source=(https://download.edgewall.org/trac/Trac-$pkgver.tar.gz
- tracd.service)
-sha256sums=('c93ceed9abee6e3c7789f469862e82a3b9bf3405be73aae3221b5c259e062d21'
- '3f050f1c9367b1b28e18a6ff0088f991676a9fbba3f5177859ce4db64f95ca42')
+source=(https://download.edgewall.org/trac/Trac-$pkgver.tar.gz)
+sha256sums=('c93ceed9abee6e3c7789f469862e82a3b9bf3405be73aae3221b5c259e062d21')
prepare() {
cd "$srcdir"/Trac-$pkgver
@@ -36,5 +33,4 @@ package() {
cd "$srcdir"/Trac-$pkgver
python2 setup.py install --prefix=/usr --root="$pkgdir"
install -D -m644 COPYING "$pkgdir"/usr/share/licenses/trac/COPYING
- install -Dm0644 "$srcdir"/tracd.service "$pkgdir"/usr/lib/systemd/system/tracd.service
}
diff --git a/trac.install b/trac.install
deleted file mode 100644
index b0ae2b13067e..000000000000
--- a/trac.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- echo "-- tracd.service is an example. Copy it into /etc/systemd/... and edit"
- echo "-- Please read http://trac.edgewall.org/wiki/TracInstall to install"
- echo "-- additional requirements"
- echo "--"
- echo "-- DB engines are mandatory!!!"
-}
-
-post_upgrade() {
- echo "-- tracd.service is an example. Copy it into /etc/systemd/... and edit"
-}
diff --git a/tracd.service b/tracd.service
deleted file mode 100644
index 7d586b2268f5..000000000000
--- a/tracd.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Trac service
-After=network.target remote-fs.target nss-lookup.target
-
-[Service]
-Type=simple
-# Example: copy it into /etc/systemd/ and edit.
-ExecStart=/usr/bin/tracd -b localhost -p 8080 --auth /tmp,/tmp/passwd,realm /tmp
-
-[Install]
-WantedBy=multi-user.target