summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2023-07-23 19:05:40 +0300
committerAnton Kudelin2023-07-23 19:05:40 +0300
commite0f6ac8a6e37a431401c0043ffc3f15dc1512542 (patch)
treeacd72b7b0a4f99a21661bed1e3a320f5066b5146
parent803b3c0b28306dd674b6015fbb674cd92c9b46f4 (diff)
downloadaur-e0f6ac8a6e37a431401c0043ffc3f15dc1512542.tar.gz
hdf5 patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD59
-rw-r--r--hdf5-1.13.patch37
-rw-r--r--skip-test.patch22
4 files changed, 69 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 319d61e480f0..e90c5031aa48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = silo
pkgdesc = A Mesh and Field I/O Library and Scientific Database
pkgver = 4.11
- pkgrel = 1
- url = https://wci.llnl.gov/simulation/computer-codes/silo
+ pkgrel = 2
+ url = https://llnl.github.io/Silo
arch = x86_64
license = BSD
makedepends = gcc-fortran
depends = qt5-base
depends = hdf5-openmpi
- source = https://wci.llnl.gov/sites/wci/files/2021-09/silo-4.11-bsd.tgz
- source = skip-test.patch
+ source = https://github.com/LLNL/Silo/releases/download/v4.11/silo-4.11-bsd.tar.gz
source = hdf5.patch
+ source = hdf5-1.13.patch
sha256sums = 6d0a85a079d48fcdcc0084ecb5fc4cfdcc64852edee780c60cb244d16f4bc4ec
- sha256sums = 83e50ccad8477ae7549ae68ab12b180e268e1f28b589b699090dbefb59f57e8b
sha256sums = 8acf1a54c3ba21699a9f1cd67aabc806643630e80795bcf9524f7eb874116bb5
+ sha256sums = fc94f615155dcb8e27c73c1f19392415081d25082fd11a7666df1886556ce368
pkgname = silo
diff --git a/PKGBUILD b/PKGBUILD
index 673969984fc5..238b450062fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Maintainer: Anton Kudelin <kudelin at proton dot me>
# Contributor: eolianoe <eolianoe [at] gmail [DoT] com>
# Contributor: Carl Rogers <carl.rogers@gmail.com>
# Contributor: Jed Brown <jed@59A2.org>
@@ -6,24 +6,24 @@
pkgname=silo
pkgver=4.11
-pkgrel=1
+pkgrel=2
pkgdesc="A Mesh and Field I/O Library and Scientific Database"
-url="https://wci.llnl.gov/simulation/computer-codes/silo"
-arch=('x86_64')
-depends=('qt5-base' 'hdf5-openmpi')
-makedepends=('gcc-fortran')
-license=('BSD')
-source=("https://wci.llnl.gov/sites/wci/files/2021-09/$pkgname-$pkgver-bsd.tgz"
- "skip-test.patch"
- "hdf5.patch")
+url="https://llnl.github.io/Silo"
+arch=(x86_64)
+depends=(qt5-base hdf5-openmpi)
+makedepends=(gcc-fortran)
+license=(BSD)
+source=(https://github.com/LLNL/Silo/releases/download/v$pkgver/$pkgname-$pkgver-bsd.tar.gz
+ hdf5.patch
+ hdf5-1.13.patch)
sha256sums=('6d0a85a079d48fcdcc0084ecb5fc4cfdcc64852edee780c60cb244d16f4bc4ec'
- '83e50ccad8477ae7549ae68ab12b180e268e1f28b589b699090dbefb59f57e8b'
- '8acf1a54c3ba21699a9f1cd67aabc806643630e80795bcf9524f7eb874116bb5')
+ '8acf1a54c3ba21699a9f1cd67aabc806643630e80795bcf9524f7eb874116bb5'
+ 'fc94f615155dcb8e27c73c1f19392415081d25082fd11a7666df1886556ce368')
prepare() {
cd "$srcdir/$pkgname-$pkgver-bsd"
patch -p0 < ../hdf5.patch
- patch -p0 < "$srcdir/skip-test.patch"
+ patch -p1 < ../hdf5-1.13.patch
sed -i 's@rocket_silo.lo@rocket_silo.lo ../src/libsiloh5.la@' \
tests/Makefile.in
}
@@ -31,28 +31,23 @@ prepare() {
build() {
cd "$srcdir/$pkgname-$pkgver-bsd"
./configure \
- --prefix=/usr \
- --enable-shared \
- --enable-optimization \
- --enable-silex \
- --enable-install-lite-headers \
- --with-x \
- --with-hdf5=/usr/include,/usr/lib \
- --with-Qt-include-dir=/usr/include/qt \
- --with-szlib=/usr/lib \
- --with-zlib=/usr/include,/usr/lib \
- CFLAGS="$CFLAGS -Wno-error=format-security" \
- CXXFLAGS="-I/usr/include/qt/QtWidgets $CXXFLAGS -fPIC" \
- FFLAGS="$FFLAGS -fallow-argument-mismatch" \
- LIBS='-L/usr/lib/openmpi -lmpi -lQt5Core -lQt5Gui -lQt5Widgets'
+ --prefix=/usr \
+ --enable-shared \
+ --enable-optimization \
+ --enable-silex \
+ --enable-install-lite-headers \
+ --with-x \
+ --with-hdf5=/usr/include,/usr/lib \
+ --with-Qt-include-dir=/usr/include/qt \
+ --with-szlib=/usr/lib \
+ --with-zlib=/usr/include,/usr/lib \
+ CFLAGS="$CFLAGS -Wno-error=format-security" \
+ CXXFLAGS="-I/usr/include/qt/QtWidgets $CXXFLAGS -fPIC" \
+ FFLAGS="$FFLAGS -fallow-argument-mismatch" \
+ LIBS='-L/usr/lib/openmpi -lmpi -lQt5Core -lQt5Gui -lQt5Widgets'
make
}
-check(){
- cd "$srcdir/$pkgname-$pkgver-bsd"
- make check CXXFLAGS="$CXXFLAGS -std=c++98"
-}
-
package(){
cd "$srcdir/$pkgname-$pkgver-bsd"
make DESTDIR="$pkgdir" install
diff --git a/hdf5-1.13.patch b/hdf5-1.13.patch
new file mode 100644
index 000000000000..161bc769f646
--- /dev/null
+++ b/hdf5-1.13.patch
@@ -0,0 +1,37 @@
+From 5dc160c7ae489b8181874dccf7ce3b8089c128f5 Mon Sep 17 00:00:00 2001
+From: Chuck Atkins <chuck.atkins@kitware.com>
+Date: Tue, 24 May 2022 10:57:29 -0400
+Subject: [PATCH] hdf5: Support the API changes in >= 1.13
+
+---
+ src/hdf5_drv/H5FDsilo.c | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/src/hdf5_drv/H5FDsilo.c b/src/hdf5_drv/H5FDsilo.c
+index f4540456..74594c1b 100644
+--- a/src/hdf5_drv/H5FDsilo.c
++++ b/src/hdf5_drv/H5FDsilo.c
+@@ -550,6 +550,12 @@ typedef struct H5FD_class_t {
+ #endif
+
+ static const H5FD_class_t H5FD_silo_g = {
++#if HDF5_VERSION_GE(1,13,2) && defined(H5FD_CLASS_VERSION)
++ H5FD_CLASS_VERSION, /*version */
++#endif
++#if HDF5_VERSION_GE(1,13,0)
++ 512, /*value */
++#endif
+ "silo", /*name */
+ MAXADDR, /*maxaddr */
+ H5F_CLOSE_WEAK, /* fc_degree */
+@@ -583,6 +589,10 @@ static const H5FD_class_t H5FD_silo_g = {
+ H5FD_silo_truncate, /*truncate */
+ NULL, /*lock */
+ NULL, /*unlock */
++#if HDF5_VERSION_GE(1,13,0)
++ NULL, /*del */
++ NULL, /*ctl */
++#endif
+ H5FD_FLMAP_SINGLE /*fl_map */
+ };
+
diff --git a/skip-test.patch b/skip-test.patch
deleted file mode 100644
index 27b77b829ede..000000000000
--- a/skip-test.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- tests/testsuite.at 2016-02-26 12:52:54.249108829 +0100
-+++ tests/testsuite.at 2016-02-26 12:58:44.184478494 +0100
-@@ -242,7 +242,7 @@
- AT_CLEANUP
- AT_SETUP(write objects)
- AT_KEYWORDS(python)
--AT_CHECK(test -z "$PYTHON" -o -z "$BROWSER" && exit 77 || $VALGRIND testonehex `pwd`,,ignore,ignore)
-+AT_CHECK(test false && exit 77 || $VALGRIND testonehex `pwd`,,ignore,ignore)
- AT_CLEANUP
-
- AT_BANNER(JSON (experimental))
---- tests/testsuite.at 2018-07-04 20:07:16.559992474 +0200
-+++ tests/testsuite.at 2018-07-04 20:07:10.693169683 +0200
-@@ -183,7 +183,7 @@
- AT_CHECK($VALGRIND csg $STARGS,,ignore)
- AT_CLEANUP
- AT_SETUP(rocket)
--AT_CHECK($VALGRIND rocket $STARGS,,ignore)
-+AT_CHECK(test false && exit 77 || $VALGRIND rocket $STARGS,,ignore)
- AT_CLEANUP
- AT_SETUP(mmadjacency)
- AT_CHECK($VALGRIND mmadjacency $STARGS,,ignore)