summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlaviu Tamas2018-11-16 18:34:36 -0500
committerFlaviu Tamas2018-11-16 18:37:17 -0500
commite1009d8bfd80cfa0a4154872e3cd1221059c5812 (patch)
treed2dd698df0be15319ab05f580df63cd4b8f44369
parent3724aad232359b42475388fbad1296a9b963fb12 (diff)
downloadaur-e1009d8bfd80cfa0a4154872e3cd1221059c5812.tar.gz
Fix bugs
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--pylote.desktop2
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 255f3dcc846f..c11b91c3cf50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = pylote-git
pkgdesc = Software making it possible to draw on the screen of the computer, like handling various instruments of geometry.
pkgver = r160.e9d7678
- pkgrel = 1
+ pkgrel = 2
url = http://pascal.peter.free.fr/pylote.html
arch = any
license = GPL
- depends = pyqt
+ depends = python-pyqt5
+ depends = qt5-webkit
conflicts = pylote
replaces = pylote
source = git+https://gitlab.com/edleh/pylote.git
source = pylote.desktop
sha256sums = SKIP
- sha256sums = 8557e071b14f22e5386715d4769aada56175fa8a266508ce42043363b30b0bd7
+ sha256sums = fc068a7425d00a6b8295ae04255cd1860df28f11055478d8d9b64e9d65671b17
pkgname = pylote-git
diff --git a/PKGBUILD b/PKGBUILD
index 6917ef466203..21a5997115b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,19 @@
_pkgname=pylote
pkgname=$_pkgname-git
pkgver=r160.e9d7678
-pkgrel=1
+pkgrel=2
pkgdesc="Software making it possible to draw on the screen of the computer, like handling various instruments of geometry."
url="http://pascal.peter.free.fr/$_pkgname.html"
license=('GPL')
arch=('any')
-depends=('pyqt')
+depends=(python-pyqt5 qt5-webkit)
conflicts=($_pkgname)
replaces=($_pkgname)
source=(
git+https://gitlab.com/edleh/$_pkgname.git
$_pkgname.desktop)
sha256sums=('SKIP'
- '8557e071b14f22e5386715d4769aada56175fa8a266508ce42043363b30b0bd7')
+ 'fc068a7425d00a6b8295ae04255cd1860df28f11055478d8d9b64e9d65671b17')
pkgver() {
cd "$_pkgname"
@@ -28,10 +28,10 @@ pkgver() {
}
package() {
- cd "${srcdir}/${_pkgname}"
- mkdir -p "${pkgdir}/usr/share/"{$pkgname,applications}
+ cd "${srcdir}/${_pkgname}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/share/"{$_pkgname,applications}
mkdir -p "${pkgdir}/usr/bin"
- cp -R * "${pkgdir}/usr/share/$pkgname"
+ cp -R * "${pkgdir}/usr/share/$_pkgname"
echo "#!/usr/bin/bash
cd '/usr/share/$_pkgname/' && python $_pkgname.pyw" > "${pkgdir}/usr/bin/$_pkgname"
chmod +x "${pkgdir}/usr/bin/$_pkgname"
diff --git a/pylote.desktop b/pylote.desktop
index 8cd81f2ab13c..ec03b0e7cf62 100644
--- a/pylote.desktop
+++ b/pylote.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Exec=pylote
Icon=/usr/share/pylote/images/icon.png
-Name=pylote
+Name=Pylote
Categories=Education;
StartupNotify=true
Terminal=false