summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2018-06-04 02:56:36 +0200
committerNarrat2018-06-04 02:57:48 +0200
commite10b104cf13868bc1bd770707255fa28fc7a68c7 (patch)
tree0140d2d5b124c01ad89760fa74becac3ff5c84fe
parentf83b9e7fb8b3a546ec64c0fc99afe85091bd2353 (diff)
downloadaur-e10b104cf13868bc1bd770707255fa28fc7a68c7.tar.gz
mynotex: Update to 1.4.1
And use the architecture specific sources feature of makepkg
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 417d0b5915f9..820aaf456d34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Jun 30 22:23:50 UTC 2016
pkgbase = mynotex
- pkgdesc = A free note-taking and notes manager software for Linux.
- pkgver = 1.4.0.0
+ pkgdesc = free note-taking and notes manager software for Linux
+ pkgver = 1.4.1.0
pkgrel = 1
url = http://sites.google.com/site/mynotex
arch = i686
@@ -10,7 +8,10 @@ pkgbase = mynotex
license = GPL
depends = sqlite3
depends = gtk2
- source = https://sites.google.com/site/mynotex/files/mynotex_1.4.0.0_.deb
+ source_i686 = https://sites.google.com/site/mynotex/files/mynotex_1.4.1.0_i386.deb
+ md5sums_i686 = 5ccdee9c57ef13a9e4902b97e86bc833
+ source_x86_64 = https://sites.google.com/site/mynotex/files/mynotex_1.4.1.0_amd64.deb
+ md5sums_x86_64 = 657979d34ffe42af2da902894825e2cf
pkgname = mynotex
diff --git a/PKGBUILD b/PKGBUILD
index 407392875594..c86efa53b223 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,24 @@
-# Maintainer: saxonbeta <saxonbeta at gmail>
+# Contributor: saxonbeta <saxonbeta at gmail>
# Contributor: goten002 <goten002@gmail.com>
# Contributor: epinull
pkgname=mynotex
-pkgver=1.4.0.0
+pkgver=1.4.1.0
pkgrel=1
-pkgdesc="A free note-taking and notes manager software for Linux."
+pkgdesc="free note-taking and notes manager software for Linux"
url="http://sites.google.com/site/mynotex"
license=('GPL')
arch=('i686' 'x86_64')
depends=('sqlite3' 'gtk2')
-
-if [ "$CARCH" = "i686" ]; then
- debarch=("i386")
- md5sums=('466763d9ffc7170ae2303e9a89a18b5f')
-fi
-
-if [ "$CARCH" = "x86_64" ]; then
- debarch=("amd64")
- md5sums=('4b4372f84636a0a4eb6df137f106e065')
-fi
-source=("https://sites.google.com/site/${pkgname}/files/${pkgname}_${pkgver}_${debarch}.deb")
-
+source_i686=("https://sites.google.com/site/${pkgname}/files/${pkgname}_${pkgver}_i386.deb")
+source_x86_64=("https://sites.google.com/site/${pkgname}/files/${pkgname}_${pkgver}_amd64.deb")
+md5sums_i686=('5ccdee9c57ef13a9e4902b97e86bc833')
+md5sums_x86_64=('657979d34ffe42af2da902894825e2cf')
package() {
-
- cd "${srcdir}"
tar -axf data.tar.xz -C "$pkgdir"
mkdir -p "${pkgdir}/usr/bin/"
ln -s "/opt/mynotex/mynotex" "${pkgdir}/usr/bin/mynotex"
-
}
+