summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSasasu2018-02-20 11:31:31 +0800
committerSasasu2018-02-20 11:31:31 +0800
commite11ced1f51e7424302be3228a9c7c9d3d9324de0 (patch)
treef9006a7cc51148ba4893a521640ead3f78adc07f
downloadaur-e11ced1f51e7424302be3228a9c7c9d3d9324de0.tar.gz
init
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD59
-rw-r--r--chrome.install13
-rw-r--r--firefox.install13
-rw-r--r--opera.install13
5 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c480f16a9bb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = uget-integrator-browser
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/ugetdm/uget-extension
+ arch = any
+ license = GPL3
+ depends = uget-integrator-bin
+ source = ugetdm-chrome-0.0.1::https://raw.githubusercontent.com/ugetdm/uget-integrator/v0.0.1/conf/com.ugetdm.chrome.json
+ source = ugetdm-firefox-0.0.1::https://raw.githubusercontent.com/ugetdm/uget-integrator/v0.0.1/conf/com.ugetdm.firefox.json
+ md5sums = 09303ac5e041a9788cf0748929cbd827
+ md5sums = 14049191a778e186d6805b65972245d9
+
+pkgname = uget-integrator-chrome
+ pkgdesc = Configuration to connect Google Chrome with uget-integrator
+ install = chrome.install
+ optdepends = google-chrome: the browser
+
+pkgname = uget-integrator-chromium
+ pkgdesc = Configuration to connect Chromium with uget-integrator
+ install = chrome.install
+ optdepends = chromium: the browser
+
+pkgname = uget-integrator-opera
+ pkgdesc = Configuration to connect Opera with uget-integrator
+ install = opera.install
+ optdepends = opera-beta: the browser beta version
+ optdepends = opera-developer: the browser developer version
+
+pkgname = uget-integrator-firefox
+ pkgdesc = Configuration to connect Firefox with uget-integrator
+ install = firefox.install
+ optdepends = firefox: the browser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93b970857cff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+#Maintainer : Sasasu <lizhaolong0123@gmail.com>
+
+pkgbase=uget-integrator-browser # or uget-integrator-extension ?
+pkgname=(uget-integrator-chrome uget-integrator-chromium uget-integrator-opera uget-integrator-firefox)
+arch=('any')
+url="https://github.com/ugetdm/uget-extension" # when uget-extension has a new release this package will auto upgrade
+license=('GPL3')
+depends=('uget-integrator-bin')
+pkgver=0.0.1
+pkgrel=1
+makedepends=()
+source=("ugetdm-chrome-$pkgver::https://raw.githubusercontent.com/ugetdm/uget-integrator/v$pkgver/conf/com.ugetdm.chrome.json"
+ "ugetdm-firefox-$pkgver::https://raw.githubusercontent.com/ugetdm/uget-integrator/v$pkgver/conf/com.ugetdm.firefox.json")
+md5sums=('09303ac5e041a9788cf0748929cbd827'
+ '14049191a778e186d6805b65972245d9')
+
+build() {
+ cd "$srcdir"
+}
+
+#for Google Chrome
+package_uget-integrator-chrome(){
+ optdepends=('google-chrome: the browser')
+ pkgdesc="Configuration to connect Google Chrome with uget-integrator"
+ install="chrome.install"
+ cd "$srcdir"
+ mkdir -p "$pkgdir/etc/opt/chrome/native-messaging-hosts"
+ install -m644 "ugetdm-chrome-$pkgver" "$pkgdir"/etc/opt/chrome/native-messaging-hosts/com.ugetdm.chrome.json
+}
+
+#for Chromium and Vivaldi
+package_uget-integrator-chromium(){
+ optdepends=('chromium: the browser')
+ pkgdesc="Configuration to connect Chromium with uget-integrator"
+ install="chrome.install"
+ cd "$srcdir"
+ mkdir -p "$pkgdir/etc/chromium/native-messaging-hosts"
+ install -m644 "ugetdm-chrome-$pkgver" "$pkgdir"/etc/chromium/native-messaging-hosts/com.ugetdm.chrome.json
+}
+
+#for Opera
+package_uget-integrator-opera(){
+ optdepends=('opera-beta: the browser beta version' 'opera-developer: the browser developer version')
+ pkgdesc="Configuration to connect Opera with uget-integrator"
+ install="opera.install"
+ cd "$srcdir"
+ mkdir -p "$pkgdir/etc/opera/native-messaging-hosts"
+ install -m644 "ugetdm-chrome-$pkgver" "$pkgdir"/etc/opera/native-messaging-hosts/com.ugetdm.chrome.json
+}
+
+#for Firefox
+package_uget-integrator-firefox(){
+ optdepends=('firefox: the browser')
+ pkgdesc="Configuration to connect Firefox with uget-integrator"
+ install="firefox.install"
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/lib/mozilla/native-messaging-hosts"
+ install -m644 "ugetdm-firefox-$pkgver" "$pkgdir"/usr/lib/mozilla/native-messaging-hosts/com.ugetdm.firefox.json
+}
diff --git a/chrome.install b/chrome.install
new file mode 100644
index 000000000000..6d52d6777884
--- /dev/null
+++ b/chrome.install
@@ -0,0 +1,13 @@
+echo_url()
+{
+ echo "https://chrome.google.com/webstore/detail/uget-integration/efjgjleilhflffpbnkaofpmdnajdpepi"
+}
+post_install()
+{
+ echo "you should install uGet Integration extension to your browser"
+ echo_url
+}
+post_upgrade() {
+ echo "you should upgrade uGet Integration extension"
+ echo_url
+}
diff --git a/firefox.install b/firefox.install
new file mode 100644
index 000000000000..759529389c1d
--- /dev/null
+++ b/firefox.install
@@ -0,0 +1,13 @@
+echo_url()
+{
+ echo "https://addons.mozilla.org/en-US/firefox/addon/ugetintegration/"
+}
+post_install()
+{
+ echo "you should install uGet Integration extension to your browser"
+ echo_url
+}
+post_upgrade() {
+ echo "you should upgrade uGet Integration extension"
+ echo_url
+}
diff --git a/opera.install b/opera.install
new file mode 100644
index 000000000000..727812b2e2c2
--- /dev/null
+++ b/opera.install
@@ -0,0 +1,13 @@
+echo_url()
+{
+ echo "https://addons.opera.com/en/extensions/details/uget-integration"
+}
+post_install()
+{
+ echo "you should install uGet Integration extension to your browser"
+ echo_url
+}
+post_upgrade() {
+ echo "you should upgrade uGet Integration extension"
+ echo_url
+}