summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-01-31 17:56:23 +0300
committerViktor Drobot2020-01-31 17:56:23 +0300
commite12f0bc70e9f0dae23f5615d6e68c36d32c6b115 (patch)
tree5c88d54875b3bd7dc5a5d29ee5749863a65b8121
downloadaur-e12f0bc70e9f0dae23f5615d6e68c36d32c6b115.tar.gz
First release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b19bff94093
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-r.methodss3
+ pkgdesc = S3 Methods Simplified
+ pkgver = 1.7.1
+ pkgrel = 1
+ url = https://cran.r-project.org/package=R.methodsS3
+ arch = any
+ license = LGPL2.1
+ license = LGPL3
+ depends = r>=2.13.0
+ source = https://cran.r-project.org/src/contrib/R.methodsS3_1.7.1.tar.gz
+ md5sums = c88e815837f268affd4f2a39c737d969
+
+pkgname = r-r.methodss3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d25d4eaffc88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=R.methodsS3
+_cranver=1.7.1
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="S3 Methods Simplified"
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(LGPL2.1 LGPL3)
+depends=('r>=2.13.0')
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('c88e815837f268affd4f2a39c737d969')
+
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}