summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-04-23 14:42:49 +0200
committerbartus2021-04-23 14:42:49 +0200
commite13fde4b9582083c0ee7ae97b4cd15f52c708bf7 (patch)
treec749a84bdc2597732813cbe2f6f1159210bf1de6
parent2c2b6669016635dee6f468e74bfa626e186c565d (diff)
downloadaur-e13fde4b9582083c0ee7ae97b4cd15f52c708bf7.tar.gz
Fix stdlib missing header
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--std.patch13
3 files changed, 20 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bf240f84553..6f24e30ca816 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,9 +25,11 @@ pkgbase = usd
source = git+https://github.com/PixarAnimationStudios/USD.git#tag=v20.05
source = boost_python2.patch
source = blender.patch
+ source = std.patch
sha256sums = SKIP
sha256sums = 2f595ce72b9fb33e6da7db97b02be11fe6262e31b83b0e59232ee8713afed97e
sha256sums = 95a4934ae8154e1650a024b09ed3237ba7d9411ada089a4b6337cbba9312705a
+ sha256sums = 5e9dfc3daa97271b959e78737079335907a3536bb8af2d74ef9b8f7529f2f8e5
pkgname = usd
diff --git a/PKGBUILD b/PKGBUILD
index 8c217704d6a6..e81f041a64ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,13 +28,15 @@ makedepends+=(boost{,-python2} 'cmake' 'git' 'intel-tbb' 'ninja')
provides=("usd=${pkgver}")
source=("git+https://github.com/PixarAnimationStudios/USD.git${_fragment}"
"boost_python2.patch"
- "blender.patch")
+ "blender.patch"
+ "std.patch")
sha256sums=('SKIP'
'2f595ce72b9fb33e6da7db97b02be11fe6262e31b83b0e59232ee8713afed97e'
- '95a4934ae8154e1650a024b09ed3237ba7d9411ada089a4b6337cbba9312705a')
+ '95a4934ae8154e1650a024b09ed3237ba7d9411ada089a4b6337cbba9312705a'
+ '5e9dfc3daa97271b959e78737079335907a3536bb8af2d74ef9b8f7529f2f8e5')
prepare() {
- git -C USD apply -v "${srcdir}"/{boost_python2,blender}.patch
+ git -C USD apply -v "${srcdir}"/{boost_python2,blender,std}.patch
}
#pkgver() {
diff --git a/std.patch b/std.patch
new file mode 100644
index 000000000000..c10ce34924c1
--- /dev/null
+++ b/std.patch
@@ -0,0 +1,13 @@
+diff --git a/pxr/usd/ar/packageUtils.cpp b/pxr/usd/ar/packageUtils.cpp
+index d497587b3..ed3df295f 100644
+--- a/pxr/usd/ar/packageUtils.cpp
++++ b/pxr/usd/ar/packageUtils.cpp
+@@ -29,6 +29,8 @@
+ #include "pxr/base/tf/pathUtils.h"
+ #include "pxr/base/tf/stringUtils.h"
+
++#include <algorithm>
++
+ PXR_NAMESPACE_OPEN_SCOPE
+
+ namespace