summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomini2021-02-26 23:56:07 +0000
committersomini2021-02-26 23:56:07 +0000
commite15e18d7c511e0fca5e0928e2dd0363c779afc7b (patch)
treecb681a9454e8b599692df47526ab1b031e27166b
parent52b05e8aab1969b9081a114a61f19eee0987a945 (diff)
downloadaur-e15e18d7c511e0fca5e0928e2dd0363c779afc7b.tar.gz
Include workaround for PolicyKit niggle
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rwxr-xr-xbucklespring.sh3
3 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94ebf94fc387..0b0a2edfd3ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bucklespring-libinput-git
pkgdesc = Nostalgia bucklespring keyboard sound, sampled from IBM's Model-M. libinput version
pkgver = latest
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/zevv/bucklespring
arch = i686
arch = x86_64
@@ -14,9 +14,11 @@ pkgbase = bucklespring-libinput-git
source = git+https://github.com/zevv/bucklespring
source = nl.zevv.bucklespring.run.policy
source = bucklespring.rules
+ source = bucklespring.sh
sha1sums = SKIP
sha1sums = 9338bf7235e9a366b349bd780cdbf329cc409210
sha1sums = 04b8a433d9d93d7cdc63303b433978f16348a78e
+ sha1sums = 4b2cf0f23893acc6849d966e4248ddd4a25f6b3b
pkgname = bucklespring-libinput-git
diff --git a/PKGBUILD b/PKGBUILD
index 16176509e819..f2f22408b311 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=bucklespring
pkgname=bucklespring-libinput-git
pkgver=latest
-pkgrel=2
+pkgrel=3
pkgdesc="Nostalgia bucklespring keyboard sound, sampled from IBM's Model-M. libinput version"
arch=('i686' 'x86_64')
url='https://github.com/zevv/bucklespring'
@@ -15,10 +15,12 @@ source=(
'git+https://github.com/zevv/bucklespring'
'nl.zevv.bucklespring.run.policy'
'bucklespring.rules'
+ 'bucklespring.sh'
)
sha1sums=('SKIP'
'9338bf7235e9a366b349bd780cdbf329cc409210'
- '04b8a433d9d93d7cdc63303b433978f16348a78e')
+ '04b8a433d9d93d7cdc63303b433978f16348a78e'
+ '4b2cf0f23893acc6849d966e4248ddd4a25f6b3b')
build() {
cd "$srcdir/$_pkgname"
@@ -29,6 +31,7 @@ package() {
cd "$srcdir/$_pkgname"
# Program
install -Dm755 buckle "$pkgdir"/usr/bin/buckle
+ install -Dm755 "$srcdir/bucklespring.sh" "$pkgdir"/usr/bin/bucklespring
# Audio
install -Dm644 -t "$pkgdir"/usr/share/bucklespring/ wav/*
diff --git a/bucklespring.sh b/bucklespring.sh
new file mode 100755
index 000000000000..5aff2701eeac
--- /dev/null
+++ b/bucklespring.sh
@@ -0,0 +1,3 @@
+#!/usr/bin/sh
+# No exec on purpose: https://askubuntu.com/a/721075
+pkexec buckle -M "$@"