summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Sarawinski2024-02-19 17:43:32 +0100
committerTimo Sarawinski2024-02-19 17:43:32 +0100
commite19dbd70e8cf63982141c770160e43fbbb3469d8 (patch)
tree8b026713ec5d2277b965ccc12af2252ce2afd9b7
parent9fe5072bfc4448f85aa21f578edb8b65c62984dc (diff)
downloadaur-e19dbd70e8cf63982141c770160e43fbbb3469d8.tar.gz
patch for mariadb 11.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--mariadb11.patch9
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bd33a68274c..1395ff7ec9a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mysqltuner
pkgdesc = MySQLTuner - review configuration quickly and make adjustments to increase performance and stability
pkgver = 2.5.3
- pkgrel = 2
+ pkgrel = 3
url = http://www.mysqltuner.com
arch = any
license = GPL
@@ -11,6 +11,6 @@ pkgbase = mysqltuner
source = mysqltuner::git+https://github.com/rackerhacker/MySQLTuner-perl.git#tag=ac43eee9692c7f5ffcbdd975c2bd370fda5868f8
source = mariadb11.patch
sha256sums = SKIP
- sha256sums = d49b85da2cb9931c16a589dd3ebdfa2cbf5ad6406186c51488404d21b23d6a2a
+ sha256sums = 23406fe34107df09ca6bc33e9cb8277b5bedc8273f966b31c108022e480cadc2
pkgname = mysqltuner
diff --git a/PKGBUILD b/PKGBUILD
index 4dca1c296316..1fd12d105ece 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mysqltuner
pkgver=2.5.3
_tag='ac43eee9692c7f5ffcbdd975c2bd370fda5868f8'
-pkgrel=2
+pkgrel=3
pkgdesc='MySQLTuner - review configuration quickly and make adjustments to increase performance and stability'
arch=('any')
url='http://www.mysqltuner.com'
@@ -13,7 +13,7 @@ depends=('perl')
source=("mysqltuner::git+https://github.com/rackerhacker/MySQLTuner-perl.git#tag=${_tag}"
"mariadb11.patch")
sha256sums=('SKIP'
- 'd49b85da2cb9931c16a589dd3ebdfa2cbf5ad6406186c51488404d21b23d6a2a')
+ '23406fe34107df09ca6bc33e9cb8277b5bedc8273f966b31c108022e480cadc2')
prepare() {
cd mysqltuner/
diff --git a/mariadb11.patch b/mariadb11.patch
index 05083365e19d..c5be10c8c1db 100644
--- a/mariadb11.patch
+++ b/mariadb11.patch
@@ -1,14 +1,15 @@
--- mysqltuner.pl
+++ mysqltuner.pl
-@@ -2446,7 +2446,10 @@
+@@ -2446,7 +2446,11 @@
or mysql_version_eq( 10, 8 )
or mysql_version_eq( 10, 9 )
or mysql_version_eq( 10, 10 )
- or mysql_version_eq( 10, 11 ) )
+ or mysql_version_eq( 10, 11 )
-+ or mysql_version_eq( 11,0 )
-+ or mysql_version_eq( 11,1 )
-+ or mysql_version_eq( 11,2 ) )
++ or mysql_version_eq( 11,0 )
++ or mysql_version_eq( 11,1 )
++ or mysql_version_eq( 11,2 )
++ or mysql_version_eq( 11,3 ) )
{
goodprint "Currently running supported MySQL version "
. $myvar{'version'} . "";