summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff-WuYo2022-09-14 01:55:09 +0800
committerJeff-WuYo2022-09-14 01:55:09 +0800
commite1b9d8e76f2e6a6703d4e08ca2e42031c328e291 (patch)
tree19a3058488a136e035d07315cb5cda0d5650a843
parentb1cc86661e6ea67bf8cad7ed8af039053809fa81 (diff)
downloadaur-e1b9d8e76f2e6a6703d4e08ca2e42031c328e291.tar.gz
add pacman hook to warn people if qt6-base being updated
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
-rw-r--r--qt6gtk2.hook9
4 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a0c92964780..3e7446944eea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt6gtk2
pkgdesc = GTK+2.0 integration plugins for Qt6
pkgver = 0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/trialuser02/qt6gtk2
arch = any
groups = therepoclub
@@ -12,7 +12,8 @@ pkgbase = qt6gtk2
depends = gtk2
conflicts = qt6gtk2-git
source = qt6gtk2-0.2.tar.gz::https://github.com/trialuser02/qt6gtk2/releases/download/0.2/qt6gtk2-0.2.tar.xz
+ source = qt6gtk2.hook
sha256sums = 22596853eb3ea663d8f28fb40d97195428b883ec571365ce1b03437f5c75f6bc
+ sha256sums = 9c60620868ce7dc469985cdde56332e28ce9f60dd13d6dfa516e8d1ef94c7673
pkgname = qt6gtk2
-
diff --git a/.gitignore b/.gitignore
index 07b96b49345c..ba6d62678c31 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
src/*
pkg/*
+qt6gtk2-0.2*
diff --git a/PKGBUILD b/PKGBUILD
index 1b38ccf9e50d..48da46528719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jeff_WuYo <62562200+Jeff-WuYo@users.noreply.github.com>
pkgname=qt6gtk2
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc='GTK+2.0 integration plugins for Qt6'
arch=('any')
groups=('therepoclub')
@@ -10,8 +10,10 @@ license=(GPL2)
conflicts=($pkgname-git)
depends=(qt6-svg qt6-base gtk2)
makedepends=(qt6-tools)
-source=("${pkgname}-$pkgver.tar.gz::${url}/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
-sha256sums=('22596853eb3ea663d8f28fb40d97195428b883ec571365ce1b03437f5c75f6bc')
+source=("${pkgname}-$pkgver.tar.gz::${url}/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+ "${pkgname}.hook")
+sha256sums=('22596853eb3ea663d8f28fb40d97195428b883ec571365ce1b03437f5c75f6bc'
+ '9c60620868ce7dc469985cdde56332e28ce9f60dd13d6dfa516e8d1ef94c7673')
build() {
cd $pkgname-$pkgver
@@ -23,4 +25,5 @@ package() {
cd $pkgname-$pkgver
make INSTALL_ROOT="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 "$srcdir/${pkgname}.hook" "$pkgdir/usr/share/libalpm/hooks/90-${pkgname}.hook"
}
diff --git a/qt6gtk2.hook b/qt6gtk2.hook
new file mode 100644
index 000000000000..fcdf4a7179cb
--- /dev/null
+++ b/qt6gtk2.hook
@@ -0,0 +1,9 @@
+[Trigger]
+Type = Package
+Operation = Upgrade
+Target = qt6-base
+
+[Action]
+Description = Qt6 Upgrade Warning
+When = PostTransaction
+Exec = /usr/bin/echo "[WARNING] qt6-base was updated, qt6 applications will break until qt6gtk2 is rebuilt."