summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2024-03-19 13:19:21 +0300
committerCaleb Maclennan2024-03-19 13:20:43 +0300
commite1bba148e7242efc826424d9eb076f394ed409ff (patch)
tree2b4387f39920e05d97bff4920c63f3ee2f7449ad
parent94892ccb3d1a2b6158a49ccc2ccdaafcd3aa6d55 (diff)
downloadaur-e1bba148e7242efc826424d9eb076f394ed409ff.tar.gz
upgpkg: libpri 1.6.1-1
upstream release
-rw-r--r--.SRCINFO15
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD26
3 files changed, 24 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c5377705a9e..fafdcba20f2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
-# Generated by mksrcinfo v8
-# Mon Sep 4 15:46:50 UTC 2017
pkgbase = libpri
pkgdesc = library that encapsulates the protocols used to communicate over ISDN Primary Rate Interfaces
- pkgver = 1.6.0
+ pkgver = 1.6.1
pkgrel = 1
- url = http://www.asterisk.org/
- arch = i686
+ url = https://github.com/asterisk/libpri
arch = x86_64
- license = GPL
+ arch = i686
+ license = GPL-2.0-only
depends = dahdi
- source = https://downloads.asterisk.org/pub/telephony/libpri/libpri-1.6.0.tar.gz
- sha256sums = 7225ea7ec334a115f9dc08e71f55589c38cb4e00b13964cd2f08cc4e6123e3f6
+ source = https://github.com/asterisk/libpri/archive/1.6.1/libpri-1.6.1.tar.gz
+ sha256sums = c38ea1b5a90a6a7a38d57fcb58f47f14d865468acf9e2e1ef0dc76e257755c7a
pkgname = libpri
-
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..2d35d11717d6
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[libpri]
+source = "github"
+github = "asterisk/libpri"
+use_max_tag = true
diff --git a/PKGBUILD b/PKGBUILD
index dc90059b6405..a0ffe6e5a3eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
-# Maintainer: twa022 <twa022 at gmail dot com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: twa022 <twa022 at gmail dot com>
pkgname=libpri
-pkgver=1.6.0
+pkgver=1.6.1
pkgrel=1
pkgdesc='library that encapsulates the protocols used to communicate over ISDN Primary Rate Interfaces'
-arch=('i686' 'x86_64')
-url='http://www.asterisk.org/'
-license=('GPL')
-depends=('dahdi')
-source=("https://downloads.asterisk.org/pub/telephony/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('7225ea7ec334a115f9dc08e71f55589c38cb4e00b13964cd2f08cc4e6123e3f6')
+arch=(x86_64 i686)
+url="https://github.com/asterisk/$pkgname"
+license=(GPL-2.0-only)
+depends=(dahdi)
+_archive="$pkgname-$pkgver"
+source=("$url/archive/$pkgver/$_archive.tar.gz")
+sha256sums=('c38ea1b5a90a6a7a38d57fcb58f47f14d865468acf9e2e1ef0dc76e257755c7a')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make
+ cd "$_archive"
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "$_archive"
+ make DESTDIR="$pkgdir" install
}