summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2022-03-01 13:04:27 +0000
committerJonathon Fernyhough2022-03-01 13:04:27 +0000
commite1c73e0bcf6827e0727371723d98c5e7dd3f2885 (patch)
treed0c73554c28cd62c92aab78752dd01897315390f
parentb89aa9402c9ae165a39edfe03f0dd0d8f8c95fea (diff)
downloadaur-e1c73e0bcf6827e0727371723d98c5e7dd3f2885.tar.gz
Narrow fortran make targets
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1ebb32eab28..a16c8b46fbea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gcc10
pkgdesc = The GNU Compiler Collection
pkgver = 10.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://gcc.gnu.org
arch = x86_64
license = GPL
@@ -35,7 +35,7 @@ pkgbase = gcc10
pkgname = gcc10
pkgdesc = The GNU Compiler Collection - C and C++ frontends (10.x.x)
- depends = gcc10-libs=10.3.0-1
+ depends = gcc10-libs=10.3.0-2
depends = binutils>=2.28
depends = libmpc
depends = zstd
@@ -56,4 +56,4 @@ pkgname = gcc10-libs
pkgname = gcc10-fortran
pkgdesc = Fortran front-end for GCC (10.x.x)
- depends = gcc10=10.3.0-1
+ depends = gcc10=10.3.0-2
diff --git a/PKGBUILD b/PKGBUILD
index a4b16a04f1de..ee9c197a3120 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=($pkgbase gcc10-libs gcc10-fortran)
pkgver=10.3.0
_majorver=${pkgver%%.*}
_islver=0.24
-pkgrel=1
+pkgrel=2
pkgdesc='The GNU Compiler Collection'
arch=(x86_64)
license=(GPL LGPL FDL custom)
@@ -214,7 +214,7 @@ package_gcc10-fortran() {
make -C $CHOST/libgfortran DESTDIR="$pkgdir" install-cafexeclibLTLIBRARIES \
install-{toolexeclibDATA,nodist_fincludeHEADERS,gfor_cHEADERS}
make -C $CHOST/libgomp DESTDIR="$pkgdir" install-nodist_fincludeHEADERS
- make -C gcc DESTDIR="$pkgdir" fortran.install-{common,man,info}
+ make -C gcc DESTDIR="$pkgdir" fortran.install-common
install -Dm755 gcc/f951 "$pkgdir/${_libdir}/f951"
ln -s gfortran-${_majorver} "$pkgdir/usr/bin/f95-${_majorver}"