summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2022-07-14 02:05:49 +0300
committerYigit Sever2022-07-14 02:05:49 +0300
commite1c7b1ab34e8dbfcf12629be9b15f34b55dd6c9b (patch)
tree9200aad842acb0e187f14a6a23723332689ad8be
parent321a6dbb36ed4bfc82e906e06304e707f485c1f2 (diff)
downloadaur-e1c7b1ab34e8dbfcf12629be9b15f34b55dd6c9b.tar.gz
update: wapiti 3.1.3-1
-rw-r--r--.SRCINFO9
-rw-r--r--ChangeLog8
-rw-r--r--PKGBUILD29
3 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b894ba8eaf9..2dfd12ff97a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wapiti
pkgdesc = Comprehensive web app vulnerability scanner written in Python
- pkgver = 3.1.2
+ pkgver = 3.1.3
pkgrel = 1
url = https://wapiti-scanner.github.io
changelog = ChangeLog
@@ -18,11 +18,14 @@ pkgbase = wapiti
depends = python-tld
depends = python-httpx
depends = python-aiocache
+ depends = python-aiosqlite
depends = python-sqlalchemy
+ depends = python-loguru
+ depends = python-cryptography
optdepends = python-requests-kerberos: Kerberos authentication
optdepends = python-requests-ntlm: NTLM authentication
options = zipman
- source = https://github.com/wapiti-scanner/wapiti/releases/download/3.1.2/wapiti3-3.1.2.tar.gz
- sha256sums = d10c51577792f949c9afa143043c9a25e6e86542cb48489d944ace45612aaea9
+ source = https://github.com/wapiti-scanner/wapiti/releases/download/3.1.3/wapiti3-3.1.3.tar.gz
+ sha256sums = 83ffef39199f92f530f7de7b47dbfb93ab2c9c97d3bbee93473084cba5796c61
pkgname = wapiti
diff --git a/ChangeLog b/ChangeLog
index 645c857ec64f..ff8f2a52c353 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+09/07/2022
+ Wapiti 3.1.3
+ Reports: Add a new --detailed-report option that will put HTTP responses (headers and bodies) in the report.
+ Crawler: Add a new --mitm-port option that will replace the crawler with an intercepting proxy (mitmproxy)
+ Core: Dropped support of Python 3.7
+
13/05/2022
Wapiti 3.1.2
mod_http_headers: Deprecate X-XSS-Protection header
@@ -343,7 +349,7 @@
GET_XSS: only scan for XSS with HTTP GET method (no post)
POST_XSS: XSS attacks using POST and not GET
GET_ALL: every attack without POST requests
-
+
12/08/2006
Version 1.1.3
Fixed the timeout bug with chunked responses
diff --git a/PKGBUILD b/PKGBUILD
index 5020cab1cda5..d6453135ec4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
-# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
+# Maintainer : Yigit Sever <yigit at yigitsever dot com>
+# Contributor : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
# Contributor : mickael9 <mickael9 at gmail dot com>
-
pkgname=wapiti
-
-pkgver=3.1.2
+pkgver=3.1.3
_name="$pkgname${pkgver:0:1}"
pkgrel=1
-
pkgdesc='Comprehensive web app vulnerability scanner written in Python'
arch=('any')
url="https://$pkgname-scanner.github.io"
license=('GPL')
-
makedepends=('python-setuptools')
depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-yaswfp'
'python-browser-cookie3' 'python-mako' 'python-python-socks' 'python-tld' 'python-httpx'
- 'python-aiocache' 'python-sqlalchemy')
+ 'python-aiocache' 'python-aiosqlite' 'python-sqlalchemy' 'python-loguru' 'python-cryptography')
optdepends=('python-requests-kerberos: Kerberos authentication'
'python-requests-ntlm: NTLM authentication')
-
options=('zipman')
-
changelog=ChangeLog
source=("https://github.com/$pkgname-scanner/$pkgname/releases/download/$pkgver/$_name-$pkgver.tar.gz")
-#source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz")
-sha256sums=('d10c51577792f949c9afa143043c9a25e6e86542cb48489d944ace45612aaea9')
-
+sha256sums=('83ffef39199f92f530f7de7b47dbfb93ab2c9c97d3bbee93473084cba5796c61')
-prepare() { rm -rf "$_name-$pkgver/tests"; }
+prepare() {
+ rm -rf "$_name-$pkgver/tests"
+}
build() {
cd "$_name-$pkgver"
+ sed -i '/mitmproxy==8.0.0/s/==8.0.0/>=8.0.0/' setup.py
+ sed -i '/dnspython==2.1.0/s/==2.1.0/>=2.1.0/' setup.py
+ sed -i '/cryptography==36.0.2/s/==36.0.2/>=36.0.2/' setup.py
+ sed -i '/browser-cookie3==0.11.4/s/==0.11.4/>=0.11.4/' setup.py
+ sed -i '/importlib_metadata==3.7.2/s/==3.7.2/>=3.7.2/' setup.py
python setup.py build
}
@@ -39,6 +39,3 @@ package() {
cd "$_name-$pkgver"
PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
-
-
-# vim: ts=2 sw=2 et ft=PKGBUILD: