summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-18 18:20:49 -0500
committerclintval2017-12-18 18:20:49 -0500
commite1d212ddeb7c096035fe9d7175e8495e3dc550ed (patch)
treec37521d3d5f564d5ad7aec23c5f18ca0725ed4eb
downloadaur-e1d212ddeb7c096035fe9d7175e8495e3dc550ed.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d9995403c7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-spectra
+ pkgdesc = Color scales and color conversion in Python
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://github.com/jsvine/spectra
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-networkx>=1.11
+ depends = python-colormath>=2.1.1
+ provides = python-spectra
+ conflicts = python-spectra
+ options = !emptydirs
+ source = https://github.com/jsvine/spectra/archive/v0.0.6.tar.gz
+ md5sums = dda5cc9d0035d7b689c6d01485f7b9fd
+
+pkgname = python-spectra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dc905987ad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-spectra'
+pkgver=0.0.6
+pkgrel=1
+pkgdesc="Color scales and color conversion in Python"
+arch=('any')
+url="https://github.com/jsvine/spectra"
+license=('MIT')
+depends=('python' 'python-networkx>=1.11' 'python-colormath>=2.1.1')
+makedepends=('python-setuptools')
+provides=('python-spectra')
+conflicts=('python-spectra')
+options=(!emptydirs)
+source=("https://github.com/jsvine/spectra/archive/v${pkgver}.tar.gz")
+md5sums=('dda5cc9d0035d7b689c6d01485f7b9fd')
+
+package() {
+ cd "${srcdir}/spectra-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}