summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2017-11-25 15:31:51 -0200
committerRafael Fontenelle2017-11-25 15:31:51 -0200
commite1edf7185135d8764f70987c0d03da9071a533bf (patch)
treeeeca6cf1b14b54825c8eed65878d6eea9fa7d340
parent260f480b684fd8d7f8549dd0fd067258399090d1 (diff)
downloadaur-e1edf7185135d8764f70987c0d03da9071a533bf.tar.gz
Add cegui-0.7 to depends array
Also apply a few changes: - Fix URL to upstream in 'url' and 'source' - remove $_ver variable, use $pkgver instead - {make,}depends: use single quotes, instead of double quotes - makedepends: remove packages provided by base/base-devel groups - move build directory creationg from build() to prepare()
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c83173050d0a..494882b6cda7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
# Generated by mksrcinfo v8
-# Mon Mar 20 00:22:27 UTC 2017
+# Sat Nov 25 17:31:39 UTC 2017
pkgbase = tsc
pkgdesc = Jump'n'run game with editor and scripting facilities, fork of SMC
pkgver = 2.0.0
- pkgrel = 2
- url = http://www.secretchronicles.de/en/
+ pkgrel = 3
+ url = https://secretchronicles.org/en/
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
makedepends = ruby
makedepends = gperf
- makedepends = pkg-config
- makedepends = bison
makedepends = boost
- makedepends = gettext
depends = sdl_image
depends = sdl_ttf
depends = sdl_mixer
@@ -25,7 +22,8 @@ pkgbase = tsc
depends = pcre
depends = gtk-update-icon-cache
depends = desktop-file-utils
- source = ftp://ftp.secretchronicles.de/releases/TSC-2.0.0.tar.xz
+ depends = cegui-0.7
+ source = https://ftp.secretchronicles.org/releases/TSC-2.0.0.tar.xz
source = tsc-2.0.0-mga-mandir.patch
source = tsc-2.0.0-issue457-utf8-rakefile.patch
source = tsc-2.0.0-mga-rename-custom-filesystem-relative.patch
diff --git a/PKGBUILD b/PKGBUILD
index 2963d6b19d44..76f094f744d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=tsc
pkgver=2.0.0
-_ver=$pkgver # $_ver was used for beta, let's keep it for a while
-pkgrel=2
+pkgrel=3
pkgdesc="Jump'n'run game with editor and scripting facilities, fork of SMC"
arch=('i686' 'x86_64')
-url="http://www.secretchronicles.de/en/"
+url='https://secretchronicles.org/en/'
license=('GPL3')
-depends=("sdl_image" "sdl_ttf" "sdl_mixer" "devil" "boost-libs" "libxml++2.6"
- "glew" "pcre" "gtk-update-icon-cache" "desktop-file-utils")
-makedepends=("cmake" "ruby" "gperf" "pkg-config" "bison" "boost" "gettext")
-source=("ftp://ftp.secretchronicles.de/releases/TSC-$_ver.tar.xz"
+depends=('sdl_image' 'sdl_ttf' 'sdl_mixer' 'devil' 'boost-libs' 'libxml++2.6'
+ 'glew' 'pcre' 'gtk-update-icon-cache' 'desktop-file-utils'
+ 'cegui-0.7')
+makedepends=('cmake' 'ruby' 'gperf' 'boost')
+source=("https://ftp.secretchronicles.org/releases/TSC-$pkgver.tar.xz"
'tsc-2.0.0-mga-mandir.patch'
'tsc-2.0.0-issue457-utf8-rakefile.patch'
'tsc-2.0.0-mga-rename-custom-filesystem-relative.patch')
@@ -26,21 +26,19 @@ prepare() {
patch -p0 -i tsc-2.0.0-mga-mandir.patch
patch -p0 -i tsc-2.0.0-issue457-utf8-rakefile.patch
patch -p0 -i tsc-2.0.0-mga-rename-custom-filesystem-relative.patch
-}
-build() {
- cd TSC-$_ver/tsc
-
+ cd TSC-$pkgver/tsc
[ -d build ] && rm -rf build
mkdir build
- cd build
+}
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
-
+build() {
+ cd TSC-$pkgver/tsc/build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd TSC-$_ver/tsc/build
+ cd TSC-$pkgver/tsc/build
make DESTDIR="$pkgdir/" install
}