summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2023-08-22 17:17:01 +1000
committerLuis Aranguren2023-08-22 17:17:01 +1000
commite2061d5d2122350c52b50700ba7d3b3c58cbd549 (patch)
treefa697f0cc1bdad72da139518a0fbd415ad02a797
parent0e42538531f2a2e80f62514893d7fe3936038572 (diff)
downloadaur-e2061d5d2122350c52b50700ba7d3b3c58cbd549.tar.gz
0.7.7.beta
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07e83510a166..0618e08af5f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zap-desktop-git
pkgdesc = Lightning wallet focused on user experience and ease of use
- pkgver = 0.7.4.beta
+ pkgver = 0.7.7.beta
pkgrel = 1
url = https://github.com/LN-Zap/zap-desktop
arch = x86_64
@@ -17,6 +17,7 @@ pkgbase = zap-desktop-git
depends = libxss
provides = zap-desktop
conflicts = zap-desktop-bin
+ conflicts = zap-desktop-appimage
source = zap-desktop-git::git+https://github.com/LN-Zap/zap-desktop.git
source = zap-desktop.desktop
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b5e0fd22a728..bc7de5e0e918 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: David Parrish <daveparrish@tutanota.com>
pkgname=zap-desktop-git
-pkgver=0.7.4.beta
+pkgver=0.7.7.beta
pkgrel=1
pkgdesc="Lightning wallet focused on user experience and ease of use"
arch=('x86_64')
@@ -13,7 +13,7 @@ source=("$pkgname::git+https://github.com/LN-Zap/zap-desktop.git"
"zap-desktop.desktop")
sha256sums=('SKIP'
'8c7a0940cced4e02b9d4dc1e2ca98f546117a079f37b91739ef70a321f86d5ee')
-conflicts=("zap-desktop-bin")
+conflicts=("zap-desktop-bin" "zap-desktop-appimage")
provides=("zap-desktop")
pkgver() {
@@ -23,8 +23,8 @@ pkgver() {
build() {
cd "$pkgname" || exit
- yarn
- npm run package
+ NODE_OPTIONS=--openssl-legacy-provider yarn
+ NODE_OPTIONS=--openssl-legacy-provider npm run package
}
package() {