aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Grimes2013-11-19 11:59:15 -0500
committerMark Grimes2013-11-19 11:59:15 -0500
commite21dc1b10b212f6d2fcd3a179b005942405ab847 (patch)
tree13b9fb64805d60d5101fc63e101599e8dd054c59
parent568e0b30f72a1d6ed4270d9d8cda4228e4ebfbe7 (diff)
downloadaur-e21dc1b10b212f6d2fcd3a179b005942405ab847.tar.gz
Revised to support local::lib etc
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD39
2 files changed, 27 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 485ef82f4080..e96f5d6d12b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = perl-nagios-plugin
pkgdesc = A family of perl modules to streamline writing Nagios plugins
- pkgver = 0.35
+ pkgver = 0.36
pkgrel = 1
url = http://search.cpan.org/dist/Nagios-Plugin
arch = any
@@ -11,8 +11,8 @@ pkgbase = perl-nagios-plugin
depends = perl-config-tiny
depends = perl-math-calc-units
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/T/TO/TONVOON/Nagios-Plugin-0.35.tar.gz
- md5sums = 96b3510798e28f3ebed8c23f4225e80e
+ source = http://search.cpan.org/CPAN/authors/id/T/TO/TONVOON/Nagios-Plugin-0.36.tar.gz
+ md5sums = b897f6d5d66a655dde7caec579efcf2e
pkgname = perl-nagios-plugin
diff --git a/PKGBUILD b/PKGBUILD
index f554bd1bbf23..2cc0a5845a00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,36 @@
-# Maintainer: sh0 <mee@sh0.org>
+# Maintainer: Mark Grimes <mgrimes at peculier.com>
pkgname=perl-nagios-plugin
-pkgver=0.35
+pkgver=0.36
pkgrel=1
pkgdesc="A family of perl modules to streamline writing Nagios plugins"
+_dist=Nagios-Plugin
arch=('any')
-url="http://search.cpan.org/dist/Nagios-Plugin"
+url="http://search.cpan.org/dist/$_dist"
license=('unknown')
depends=('perl>=5.10.0' 'perl-params-validate' 'perl-class-accessor' 'perl-config-tiny' 'perl-math-calc-units')
options=(!emptydirs)
-source=(http://search.cpan.org/CPAN/authors/id/T/TO/TONVOON/Nagios-Plugin-$pkgver.tar.gz)
-md5sums=('96b3510798e28f3ebed8c23f4225e80e')
+source=(http://search.cpan.org/CPAN/authors/id/T/TO/TONVOON/$_dist-$pkgver.tar.gz)
+md5sums=('b897f6d5d66a655dde7caec579efcf2e')
-build() {
- cd "$srcdir/Nagios-Plugin-$pkgver"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+build() (
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
make
-}
+)
-package() {
- cd "$srcdir/Nagios-Plugin-$pkgver"
- make install DESTDIR="$pkgdir/"
- find $pkgdir -name '.packlist' -delete
- find $pkgdir -name '*.pod' -delete
-}
+check() (
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+)
+
+package() (
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+)
# vim:set ts=2 sw=2 et: