summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Talker2015-12-15 19:54:33 +0300
committerAlex Talker2015-12-15 19:54:33 +0300
commite23e466820d3a5cb32712ba463869845eeaaf067 (patch)
tree99a0f6ed74094740f68df4540a873d57b57498a6
parentb906cb155e4503628cebc02b05c7e1252d6d65f5 (diff)
downloadaur-e23e466820d3a5cb32712ba463869845eeaaf067.tar.gz
Fix up package name.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c13829e62a5..2c155f682185 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = wicd
+pkgbase = wicd-patched
pkgdesc = Wired and wireless network manager for Linux. Include patches that fix wicd-curses bugs.
pkgver = 1.7.3
pkgrel = 1
diff --git a/PKGBUILD b/PKGBUILD
index 833b2dde92de..a3a0ab95083b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
# Contributor: Rashif "Don Ray" Rahman <rayrashif@gmail.com>
-pkgbase='wicd'
+_pkgbase='wicd'
pkgname='wicd-patched'
pkgver=1.7.3
pkgrel=1
@@ -34,7 +34,7 @@ makedepends=('python2' 'python2-babel' 'python2-setuptools' 'gettext' 'dbus-glib
options=('emptydirs')
prepare() {
- cd $pkgbase-$pkgver
+ cd $_pkgbase-$pkgver
find . -type f -exec sed -i 's@#!/usr.*python@#!/usr/bin/python2@' {} \;
sed -i 's/pybabel/pybabel2/g' setup.py
@@ -47,7 +47,7 @@ prepare() {
}
build() {
- cd $pkgbase-$pkgver
+ cd $_pkgbase-$pkgver
python2 setup.py configure \
--no-install-init \
--resume=/usr/share/wicd/scripts/ \
@@ -67,7 +67,7 @@ build() {
}
package() {
- cd $pkgbase-$pkgver
+ cd $_pkgbase-$pkgver
python2 setup.py install --skip-build --optimize=1 --root="$pkgdir"
cd build/lib/wicd