summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsgerwk2020-07-22 15:35:16 +0200
committersgerwk2020-07-22 15:40:59 +0200
commite24657119e6d43b222000fe339896a3635cacc46 (patch)
treead9ea1c42e2a419d56e0bbed11646aee588542b1
parent45292d42c2a9278fceadfc9a420d0b2d5fd7bfe4 (diff)
downloadaur-e24657119e6d43b222000fe339896a3635cacc46.tar.gz
fix pkgname
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffa1de133a0c..d190c0e95737 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer sgerwk <sgerwk at aol dot com>
-pkgname=felinks-python
+_pkgname=felinks
+pkgname=${_pkgname}-python
pkgver=0.13.3
pkgrel=1
pkgdesc="the elinks text browser, with Python support"
@@ -13,7 +14,7 @@ source=(git+https://github.com/rkd77/felinks#tag=v$pkgver)
sha256sums=('SKIP')
build() {
- cd $startdir/src/$pkgname
+ cd $startdir/src/${_pkgname}
./autogen.sh
LDFLAGS="$(echo "$LDFLAGS" | sed 's/,--as-needed//')"
./configure --prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc \
@@ -25,12 +26,12 @@ build() {
}
check() {
- cd $startdir/src/$pkgname
+ cd $startdir/src/${_pkgname}
return $(test -x src/elinks)
}
package() {
- cd $startdir/src/$pkgname
- make DESTDIR=$startdir/pkg/$pkgname install
+ cd $startdir/src/${_pkgname}
+ make DESTDIR=$pkgdir install
rm -f $startdir/pkg/$pkgname/usr/share/locale/locale.alias
}