summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2024-04-03 10:36:40 +0200
committerGilrain2024-04-03 10:36:40 +0200
commite24fcde698b4379bd2a2f6f46460baf2b5573594 (patch)
tree096efdefc84f6559bd10c9fcebe8fc9f87386b31
parenta0f74f3fab80b3c3641e43f0a717f4bedf4414b2 (diff)
downloadaur-e24fcde698b4379bd2a2f6f46460baf2b5573594.tar.gz
Update to 6.0.1.24-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--changelog18
3 files changed, 35 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd7c1c132ce6..356344e3029f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = asf
- pkgver = 6.0.0.3
+ pkgver = 6.0.1.24
pkgrel = 1
url = https://github.com/JustArchiNET/ArchiSteamFarm
install = install
@@ -11,7 +11,7 @@ pkgbase = asf
makedepends = git
makedepends = dotnet-sdk>=8.0
makedepends = aspnet-runtime>=8.0
- source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=6.0.0.3?signed
+ source = asf::git+https://github.com/JustArchiNET/ArchiSteamFarm.git#tag=6.0.1.24?signed
source = service.patch
source = asf.env
source = ASF.json
@@ -35,6 +35,10 @@ pkgname = asf-plugin-mobileauthenticator
pkgdesc = MobileAuthenticator plugin for ArchiSteamFarm.
depends = asf
+pkgname = asf-plugin-monitoring
+ pkgdesc = Monitoring plugin for ArchiSteamFarm.
+ depends = asf
+
pkgname = asf-plugin-periodicgc
pkgdesc = PeriodicGC plugin for ArchiSteamFarm.
depends = asf
diff --git a/PKGBUILD b/PKGBUILD
index 29cddf8a3534..c9311c3e4e1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,11 @@ pkgbase=asf
pkgname=('asf-plugin-steamtokendumper'
'asf-plugin-itemsmatcher'
'asf-plugin-mobileauthenticator'
+ 'asf-plugin-monitoring'
'asf-plugin-periodicgc'
'asf-plugin-signinwithsteam'
'asf')
-pkgver="6.0.0.3"
+pkgver="6.0.1.24"
pkgrel=1
arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/JustArchiNET/ArchiSteamFarm"
@@ -51,6 +52,7 @@ build() {
dotnet publish "ArchiSteamFarm.OfficialPlugins.ItemsMatcher" -o "out/result/plugins/ArchiSteamFarm.OfficialPlugins.ItemsMatcher" $DOTNET_FLAGS $PUBLISH_FLAGS
dotnet publish "ArchiSteamFarm.OfficialPlugins.SteamTokenDumper" -o "out/result/plugins/ArchiSteamFarm.OfficialPlugins.SteamTokenDumper" $DOTNET_FLAGS $PUBLISH_FLAGS
dotnet publish "ArchiSteamFarm.OfficialPlugins.MobileAuthenticator" -o "out/result/plugins/ArchiSteamFarm.OfficialPlugins.MobileAuthenticator" $DOTNET_FLAGS $PUBLISH_FLAGS
+ dotnet publish "ArchiSteamFarm.OfficialPlugins.Monitoring" -o "out/result/plugins/ArchiSteamFarm.OfficialPlugins.Monitoring" $DOTNET_FLAGS $PUBLISH_FLAGS
dotnet publish "ArchiSteamFarm.CustomPlugins.PeriodicGC" -o "out/result/plugins/ArchiSteamFarm.CustomPlugins.PeriodicGC" $DOTNET_FLAGS $PUBLISH_FLAGS
dotnet publish "ArchiSteamFarm.CustomPlugins.SignInWithSteam" -o "out/result/plugins/ArchiSteamFarm.CustomPlugins.SignInWithSteam" $DOTNET_FLAGS $PUBLISH_FLAGS
}
@@ -84,6 +86,14 @@ package_asf-plugin-mobileauthenticator() {
mv asf/out/result/plugins/ArchiSteamFarm.OfficialPlugins.MobileAuthenticator "${pkgdir}/usr/lib/asf/plugins/"
}
+package_asf-plugin-monitoring() {
+ pkgdesc="Monitoring plugin for ArchiSteamFarm."
+ depends=('asf')
+
+ install -d -m 755 ${pkgdir}/usr/lib/asf/plugins/ArchiSteamFarm.OfficialPlugins.Monitoring
+ mv asf/out/result/plugins/ArchiSteamFarm.OfficialPlugins.Monitoring "${pkgdir}/usr/lib/asf/plugins/"
+}
+
package_asf-plugin-periodicgc() {
pkgdesc="PeriodicGC plugin for ArchiSteamFarm."
depends=('asf')
diff --git a/changelog b/changelog
index 3b51d0a251dc..1de254373ab2 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,21 @@
+2024-04-03 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 6.0.1.24-1:
+ Fixed crash when running win-x64 ASF variant on the very old CPUs (@JustArchi #3180).
+ Added automatic plugin updates functionality. This feature requires appropriate support at plugin level, and allows plugin authors to issue updates easily through unified ASF mechanisms. Plugin updates are disabled by default, you can control that behaviour with PluginsUpdateMode and PluginsUpdateList global config properties (@JustArchi #3151).
+ Added support for ASF downgrade in update command, simply append ! character to the end of update channel (@JustArchi).
+ Added updateplugins command, which allows to update plugins manually on demand, similar to update command that updates ASF - also supports ! downgrading. In addition to that, added POST /Api/Plugins/Update for IPC (@JustArchi).
+ Added initial support for new Steam families. ASF now extracts family members and gives them FamilySharing access to the bot instance automatically on top of the old family sharing system, which is still being used (@JustArchi #3162).
+ Added support for FamilyJoin 2FA confirmation type (@ezhevita #3166).
+ Added ArchiSteamFarm.OfficialPlugins.Monitoring. This is the first official ASF plugin that doesn't come bundled with the release. Instead, a zip file is provided in each release for those interested, with an optional capability of automatic updates explained above. The plugin is currently considered experimental and requires more polishing and documentation before becoming useful, but it's already made available for those interested (@Abrynos #3160).
+ Improved performance of loading own inventories by moving logic over to Steam network. This also makes some breaking changes for plugin creators (@ezhevita #3155, @Citrinate #3164).
+ ASF will now try to flash its console window on Windows when expecting user input (@ezhevita #3158 #2998).
+ Added limited support for --minimized command-line switch also for Linux and OS X (@ezhevita #3158 #3159).
+ ASF now uses minimal amount of dependencies for its IPC initialization, this slightly decreases memory footprint (@JustArchi).
+ Fixed possible ASF crash when logging in as child account in new Steam families (@JustArchi).
+ Improved core ASFB routines to not hold ASF update and trade offers blocked for too long when timeouts occur (@JustArchi).
+ Latest ASF-ui with new features, improvements and bugfixes (@MrBurrBurr).
+ Updated localization provided by our community (@JustArchi-ArchiBot).
+ Usual amount of other core improvements, optimizations and bugfixes (@JustArchi).
2024-03-02 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 6.0.0.3-1:
[!] ASF V6 comes with modern System.Text.Json replacement of previously used since the very first ASF version, Newtonsoft.Json library. This is core foundation that ASF is based on - while it should be mostly transparent for end-users, it's breaking change for existing ASF plugins, and it also has far bigger scope than usual in terms of ASF codebase, hence V6 major version bump. If you're plugin creator, you can find notes below for technical details in regards to upgrade (@JustArchi #3145 #3061).