summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoricasdri2016-02-10 20:06:22 -0500
committericasdri2016-02-10 20:06:22 -0500
commite260f2db2c95ac966c2ac408d52f1cd0e1e9f151 (patch)
treebe9e8f2c72b887bd3e0e24abcff1e533ad08a900
downloadaur-e260f2db2c95ac966c2ac408d52f1cd0e1e9f151.tar.gz
Iniitial commit (with install file)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--diff-so-fancy-git.install9
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d88caa06c1a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Feb 11 01:05:34 UTC 2016
+pkgbase = diff-so-fancy-git
+ pkgdesc = Good-looking diffs with diff-highlight and more (git version)
+ pkgver = v0.1.2.r27.g1544df3
+ pkgrel = 1
+ url = https://github.com/stevemao/diff-so-fancy
+ install = diff-so-fancy-git.install
+ arch = any
+ license = MIT
+ provides = diff-so-fancy
+ conflicts = diff-so-fancy
+ source = git+https://github.com/stevemao/diff-so-fancy.git
+ sha384sums = SKIP
+
+pkgname = diff-so-fancy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7cd80823071
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer icasdri <icasdri at gmail dot com>
+
+_pkgname=diff-so-fancy
+pkgname=diff-so-fancy-git
+pkgver=v0.1.2.r27.g1544df3
+pkgrel=1
+pkgdesc="Good-looking diffs with diff-highlight and more (git version)"
+arch=(any)
+url="https://github.com/stevemao/diff-so-fancy"
+license=('MIT')
+provides=('diff-so-fancy')
+conflicts=('diff-so-fancy')
+install="${pkgname}.install"
+source=("git+${url}.git")
+sha384sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 'diff-so-fancy' "${pkgdir}/usr/bin/diff-so-fancy"
+ install -Dm755 'third_party/diff-highlight/diff-highlight' "${pkgdir}/usr/bin/diff-highlight"
+}
diff --git a/diff-so-fancy-git.install b/diff-so-fancy-git.install
new file mode 100644
index 000000000000..870d5ff39f89
--- /dev/null
+++ b/diff-so-fancy-git.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo
+ echo "==> If you desire git-diff to use diff-so-fancy by default,"
+ echo "==> set diff-so-fancy as your global pager with the following:"
+ echo "==> git config --global core.pager 'diff-so-fancy | less --tabs=1,5 -R'"
+ echo "==> Or for one-off usage, use:"
+ echo "==> git diff --color | diff-so-fancy"
+ echo
+}