summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2019-07-24 23:10:59 +0200
committerJosip Ponjavic2019-07-24 23:10:59 +0200
commite263d311c84316be6733cc200de894a1e20bbcaa (patch)
tree7b69e58dfbb22cba717d5ff68efda8c57b220e42
parente91224699b8b591712a83b4f7436fd906e0c629c (diff)
downloadaur-e263d311c84316be6733cc200de894a1e20bbcaa.tar.gz
5.2.2-2 (clr 5.2.2-807)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--linux.install24
3 files changed, 28 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 724d42512f94..b1c997cbdb7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-clear
pkgver = 5.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/clearlinux-pkgs/linux
arch = x86_64
license = GPL2
@@ -15,7 +15,7 @@ pkgbase = linux-clear
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.2.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.2.tar.sign
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-5.2.2.xz
- source = clearlinux::git+https://github.com/clearlinux-pkgs/linux.git#tag=5.2.2-802
+ source = clearlinux::git+https://github.com/clearlinux-pkgs/linux.git#tag=5.2.2-807
source = intel-ucode-20190618.tar.gz::https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/archive/microcode-20190618.tar.gz
source = enable_additional_cpu_optimizations-20190714.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20190714.tar.gz
source = add-acs-overrides.patch::https://aur.archlinux.org/cgit/aur.git/plain/add-acs-overrides.patch?h=linux-vfio
diff --git a/PKGBUILD b/PKGBUILD
index ad643575965f..f8a3867b847c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -65,10 +65,10 @@ _enable_acs_override="y"
_major=5.2
_minor=2
_srcname=linux-${_major}
-_clr=${_major}.2-802
+_clr=${_major}.2-807
pkgbase=linux-clear
pkgver=${_major}.${_minor}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux"
license=('GPL2')
diff --git a/linux.install b/linux.install
index bb2f675cbb05..f15febe2ff38 100644
--- a/linux.install
+++ b/linux.install
@@ -1,5 +1,29 @@
+#!/bin/bash
+
+_5_2_2_2_changes() {
+ echo ':: Kernel command line update: add page_alloc.shuffle=1'
+}
+
+post_install() {
+ echo ":: Adjust kernel command line in your bootloader to Clear Linux kernel default:"
+ echo " quiet console=tty0 console=ttyS0,115200n8 cryptomgr.notests initcall_debug"
+ echo " intel_iommu=igfx_off kvm-intel.nested=1 no_timer_check noreplace-smp"
+ echo " page_alloc.shuffle=1 rcu_nocbs=0-64 rcupdate.rcu_expedited=1"
+ echo " rootfstype=ext4,btrfs,xfs tsc=reliable rw "
+}
+
post_upgrade() {
if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
echo "WARNING: /boot appears to be a separate partition but is not mounted."
fi
+
+ local v upgrades=(
+ 5.2.2-2
+ )
+
+ for v in "${upgrades[@]}"; do
+ if [[ $(vercmp "$v" "$2") -eq 1 ]]; then
+ "_${v//[.-]/_}_changes"
+ fi
+ done
}