summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElaina Martineau2019-03-09 23:57:12 -0700
committerElaina Martineau2019-03-09 23:57:12 -0700
commite271bcdb86f26fe5540361fc9bd951c96418741c (patch)
tree579a2f1a598e59653d2d858ed6c4c56974cbd41d
parent07ea802d304a93e1ffe66d22c43b52e0be8a6633 (diff)
downloadaur-e271bcdb86f26fe5540361fc9bd951c96418741c.tar.gz
Remove -march=native, add LDFLAGS
-rw-r--r--.SRCINFO4
-rwxr-xr-x[-rw-r--r--]PKGBUILD9
-rw-r--r--package.patch34
3 files changed, 41 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b037923c1d5..0c7ba9235128 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bsnes
pkgdesc = Super Nintendo emulator focusing on performance, features, and ease of use.
pkgver = 107
- pkgrel = 2
+ pkgrel = 3
url = https://byuu.org/emulation/bsnes/
arch = x86_64
license = GPL3
@@ -14,7 +14,9 @@ pkgbase = bsnes
conflicts = bsnes-classic
conflicts = bsnes-plus
source = https://download.byuu.org/bsnes_v107-source.7z
+ source = package.patch
sha256sums = 7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36
+ sha256sums = 7fd8edb835667363a77cb9b2f58f5e5d2c87c32b249afe3edb26d5ae2eecbbd6
pkgname = bsnes
diff --git a/PKGBUILD b/PKGBUILD
index c5527c4f3d20..91546f63fcf5 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,20 @@
pkgname=bsnes
pkgver=107
-pkgrel=2
+pkgrel=3
pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use.'
arch=('x86_64')
url='https://byuu.org/emulation/bsnes/'
license=('GPL3')
depends=('libpulse' 'gtksourceview2' 'libxv' 'libao' 'openal' 'sdl2')
conflicts=('bsnes-classic' 'bsnes-plus')
-source=("https://download.byuu.org/""$pkgname""_v""$pkgver""-source.7z")
-sha256sums=('7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36')
+source=("https://download.byuu.org/""$pkgname""_v""$pkgver""-source.7z" 'package.patch')
+sha256sums=('7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36' '7fd8edb835667363a77cb9b2f58f5e5d2c87c32b249afe3edb26d5ae2eecbbd6')
prepare() {
cd "$pkgname""_v""$pkgver""-source"
- # Allow us to build as root
- sed -i '37 d; 38 d; 39 s/else //' higan/target-bsnes/GNUmakefile
+ patch --forward --strip=1 --input="${srcdir}/package.patch"
}
build() {
diff --git a/package.patch b/package.patch
new file mode 100644
index 000000000000..dc9260184cde
--- /dev/null
+++ b/package.patch
@@ -0,0 +1,34 @@
+diff --unified --recursive --text package.orig/higan/GNUmakefile package.new/higan/GNUmakefile
+--- package.orig/higan/GNUmakefile 2018-12-21 12:10:31.000000000 -0700
++++ package.new/higan/GNUmakefile 2019-03-09 23:28:46.600329596 -0700
+@@ -23,7 +23,6 @@
+ endif
+ else ifneq ($(filter $(platform),linux bsd),)
+ ifeq ($(binary),application)
+- flags += -march=native
+ link += -Wl,-export-dynamic
+ link += -lX11 -lXext
+ else ifeq ($(binary),library)
+diff --unified --recursive --text package.orig/higan/target-bsnes/GNUmakefile package.new/higan/target-bsnes/GNUmakefile
+--- package.orig/higan/target-bsnes/GNUmakefile 2018-12-20 03:55:21.000000000 -0700
++++ package.new/higan/target-bsnes/GNUmakefile 2019-03-09 23:07:11.462473491 -0700
+@@ -21,7 +21,7 @@
+
+ all: $(hiro.objects) $(ruby.objects) $(objects)
+ $(info Linking out/$(name) ...)
+- +@$(compiler) -o out/$(name) $(hiro.objects) $(ruby.objects) $(objects) $(hiro.options) $(ruby.options) $(options)
++ +@$(compiler) -o out/$(name) $(hiro.objects) $(ruby.objects) $(objects) $(hiro.options) $(ruby.options) $(options) $(LDFLAGS)
+ ifeq ($(platform),macos)
+ rm -rf out/$(name).app
+ mkdir -p out/$(name).app/Contents/MacOS/
+@@ -34,9 +34,7 @@
+ verbose: hiro.verbose ruby.verbose nall.verbose all;
+
+ install: all
+-ifeq ($(shell id -un),root)
+- $(error "make install should not be run as root")
+-else ifeq ($(platform),windows)
++ifeq ($(platform),windows)
+ else ifeq ($(platform),macos)
+ mkdir -p ~/Library/Application\ Support/$(name)/
+ cp -R out/$(name).app /Applications/$(name).app