summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-03-22 12:13:08 -0600
committerMark Wagie2023-03-22 12:13:08 -0600
commite279c3447496f53bb8790d5aa6e690f706af4adc (patch)
tree69de9e4efbc67474d7819c4d797f3af1f0ee100e
parentdfa551d274943ddce2b8454aa1ab23cc0aa06bb7 (diff)
downloadaur-e279c3447496f53bb8790d5aa6e690f706af4adc.tar.gz
4.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bd38eca6291..86c3ac11fa38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
pkgbase = commit
pkgdesc = Commit message editor.
- pkgver = 3.3.0
+ pkgver = 4.0
pkgrel = 1
url = https://apps.gnome.org/app/re.sonny.Commit
- arch = x86_64
+ arch = any
license = GPL3
checkdepends = appstream-glib
+ makedepends = blueprint-compiler
+ makedepends = git
makedepends = meson
depends = libadwaita
depends = gjs
depends = gtksourceview5
optdepends = git: git support
optdepends = mercurial: mercurial support
- source = commit-3.3.0.tar.gz::https://github.com/sonnyp/Commit/archive/refs/tags/v3.3.0.tar.gz
- sha256sums = b993a2786b022b748959ba096fdf9248ab02ca52b400295484e0646e8ff220a4
+ source = git+https://github.com/sonnyp/Commit.git#commit=296e3fcc2990e3197c30d308cf1ce577ffddc044
+ source = git+https://github.com/sonnyp/troll.git
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = commit
diff --git a/PKGBUILD b/PKGBUILD
index a9feba9437f3..93a36ec68369 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,33 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=commit
-pkgver=3.3.0
+pkgver=4.0
pkgrel=1
pkgdesc="Commit message editor."
-arch=('x86_64')
+arch=('any')
url="https://apps.gnome.org/app/re.sonny.Commit"
license=('GPL3')
depends=('libadwaita' 'gjs' 'gtksourceview5')
-makedepends=('meson')
+makedepends=('blueprint-compiler' 'git' 'meson')
checkdepends=('appstream-glib')
optdepends=('git: git support'
'mercurial: mercurial support'
# 'gspell: spell checking support' # Spell checking has been temporarily removed
)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/sonnyp/Commit/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('b993a2786b022b748959ba096fdf9248ab02ca52b400295484e0646e8ff220a4')
+_commit=296e3fcc2990e3197c30d308cf1ce577ffddc044 # tags/v4.0^0
+source=("git+https://github.com/sonnyp/Commit.git#commit=$_commit"
+ 'git+https://github.com/sonnyp/troll.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd Commit
+ git submodule init
+ git config submodule.src/troll.url "$srcdir/troll"
+ git -c protocol.file.allow=always submodule update
+}
build() {
- arch-meson Commit-$pkgver build
+ arch-meson Commit build
meson compile -C build
}