summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2024-02-07 20:09:57 -0400
committerDarvin Delgado2024-02-07 20:09:57 -0400
commite27a377b14967bd6e00838c2e20de8a9426fd442 (patch)
tree7f3fc67ee166d1d76fbcebfefb0b1b62e115cf4c
parentc2713b0ebf0869d3fadc7521a102ca72a953ee8d (diff)
downloadaur-e27a377b14967bd6e00838c2e20de8a9426fd442.tar.gz
add vulkan-headers to makedepends array
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea5cd204f574..88fd9efe2a62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-mangohud-git
pkgdesc = 32-bit libraries for MangoHud and MangoApp
- pkgver = 0.7.0.r11.gefd1c07
+ pkgver = 0.7.1.r0.g48d8426
pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = lib32-mangohud-git
makedepends = meson
makedepends = nlohmann-json
makedepends = python-mako
+ makedepends = vulkan-headers
depends = lib32-dbus
depends = lib32-gcc-libs
depends = lib32-libx11
diff --git a/PKGBUILD b/PKGBUILD
index 789f803f7184..9a0c1b273083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
pkgname=lib32-mangohud-git
-pkgver=0.7.0.r11.gefd1c07
+pkgver=0.7.1.r0.g48d8426
pkgrel=1
pkgdesc="32-bit libraries for MangoHud and MangoApp"
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('git' 'glslang' 'lib32-cmocka' 'lib32-libglvnd' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako')
+makedepends=('git' 'glslang' 'lib32-cmocka' 'lib32-libglvnd' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako' 'vulkan-headers')
depends=('lib32-dbus' 'lib32-gcc-libs' 'lib32-libx11' 'lib32-sdl2' 'lib32-vulkan-icd-loader')
provides=('lib32-mangohud')
conflicts=('lib32-mangohud')
@@ -16,7 +16,7 @@ sha512sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ git describe --tags --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {