summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:38:33 +0200
committerTim Rakowski2017-05-22 19:26:28 +0200
commite27b9a965605988eefcbca40050be68c44766a73 (patch)
tree6efeb5df4c1c412fcd1032d5c51b9b46fe4b275a
downloadaur-e27b9a965605988eefcbca40050be68c44766a73.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD60
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29ef00615a6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:37 UTC 2017
+pkgbase = ros-lunar-rosclean
+ pkgdesc = ROS - rosclean: cleanup filesystem resources (e.g.
+ pkgver = 1.14.0
+ pkgrel = 1
+ url = http://ros.org/wiki/rosclean
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ depends = python2-rospkg
+ source = ros-lunar-rosclean-1.14.0-0.tar.gz::https://github.com/ros-gbp/ros-release/archive/release/lunar/rosclean/1.14.0-0.tar.gz
+ sha256sums = 3d2b804fa3c59d56b741bcc54cbbecafacbe826392f2e9e83971686daad908a2
+
+pkgname = ros-lunar-rosclean
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fe63c9f3005
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rosclean: cleanup filesystem resources (e.g."
+url='http://ros.org/wiki/rosclean'
+
+pkgname='ros-lunar-rosclean'
+pkgver='1.14.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rosclean/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros-release-release-lunar-rosclean-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/lunar/rosclean/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('3d2b804fa3c59d56b741bcc54cbbecafacbe826392f2e9e83971686daad908a2')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}