summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 07:14:37 -0600
committerBrian Bidulock2015-06-10 07:14:37 -0600
commite290c733f0e11ec5072d2037f553fef956ceb715 (patch)
tree7fccc21444de83db1e246e8b3450fc45660d9160
downloadaur-e290c733f0e11ec5072d2037f553fef956ceb715.tar.gz
initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb7f5317fa60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mount-gtk2-git
+ pkgdesc = A graphical front end for udisks and mount
+ pkgver = 1.4.3.r2.g386125b
+ pkgrel = 1
+ epoch = 1
+ url = http://mount-gtk.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = c++-gtk-utils-gtk2
+ depends = udisks2
+ depends = libnotify
+ provides = mount-gtk=1.4.3.r2.g386125b
+ conflicts = mount-gtk
+ options = !buildflags
+ options = !emptydirs
+ source = mount-gtk2-git::git://mount-gtk.git.sourceforge.net/gitroot/mount-gtk/mount-gtk
+ sha256sums = SKIP
+
+pkgname = mount-gtk2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79ec29beda01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: TDY <tdy@archlinux.info>
+# Contributor: jsteel <mail at jsteel dot org>
+# Contributor: anonymous_user <31337h4ck3r at gmail dot com>
+# Contributor: Christoph Zeiler <rabyteNOSPAM_at_gmx.dot.org>
+
+pkgname=mount-gtk2-git
+_pkgname=mount-gtk
+epoch=1
+pkgver=1.4.3.r2.g386125b
+pkgrel=1
+pkgdesc="A graphical front end for udisks and mount"
+arch=('i686' 'x86_64')
+url="http://mount-gtk.sourceforge.net/"
+license=('GPL')
+provides=($_pkgname=$pkgver)
+conflicts=($_pkgname)
+makedepends=('git')
+depends=('c++-gtk-utils-gtk2' 'udisks2' 'libnotify')
+options=('!buildflags' '!emptydirs')
+source=($pkgname::git://mount-gtk.git.sourceforge.net/gitroot/mount-gtk/mount-gtk)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "1.4.3.r%s.g%s" "$(git rev-list --count a8c9118b..HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $pkgname
+ autoreconf -fiv
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr --with-gtk-version=gtk2
+ make V=0
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: