summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-10-26 13:28:22 +0200
committertytan6522021-10-26 13:28:22 +0200
commite2a7fe85927265647de7565862c57266f32e34a1 (patch)
tree3e121c832017db489f5695271102e017cac48962
parentd84cd5e0945a95e8618a289eadceec012b5c2faf (diff)
downloadaur-e2a7fe85927265647de7565862c57266f32e34a1.tar.gz
build: Nitpicking
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a53784e03332..f3827ed3d4d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = obs-source-record
makedepends = git
makedepends = libxcomposite
depends = obs-studio>=27.0.0
- source = obs-source-record-0.2.6::git+https://github.com/exeldro/obs-source-record#commit=294575c40cf7dbca420b37030640c0d8956e9c30
+ source = obs-source-record::git+https://github.com/exeldro/obs-source-record#commit=294575c40cf7dbca420b37030640c0d8956e9c30
source = obs-studio-27.0.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.0.0.tar.gz
sha256sums = SKIP
sha256sums = c7ea5369f4c94203a8a81b73c6372873f08ab9e5b20860691dad2c29f5dda85e
diff --git a/PKGBUILD b/PKGBUILD
index b8013ed29303..7f29ab7ae16d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
+
_pluginname=source-record
pkgname=obs-$_pluginname
pkgver=0.2.6
@@ -11,7 +12,7 @@ license=("GPL2")
depends=("obs-studio>=$_obsver")
makedepends=("cmake" "git" "libxcomposite")
source=(
- "$pkgname-$pkgver::git+https://github.com/exeldro/obs-source-record#commit=294575c40cf7dbca420b37030640c0d8956e9c30"
+ "$pkgname::git+https://github.com/exeldro/$pkgname#commit=294575c40cf7dbca420b37030640c0d8956e9c30"
"obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
)
sha256sums=(
@@ -23,8 +24,8 @@ prepare() {
rm -rf fakeroot
cd "obs-studio-$_obsver"/plugins
- cp -r "$srcdir/$pkgname-$pkgver" .
- echo "add_subdirectory($pkgname-$pkgver)" | tee -a CMakeLists.txt >/dev/null
+ cp -r "$srcdir/$pkgname" .
+ echo "add_subdirectory($pkgname)" | tee -a CMakeLists.txt >/dev/null
}
# Need to compile plugin in OBS compilation process