summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAerandir2015-06-09 19:39:36 +0200
committerAerandir2015-06-09 19:39:36 +0200
commite2b06fa83044b6fc1372f97a43aee00ca44d2dcc (patch)
treebb0b5ed84bfc7447c647f551ffd8631ba58aec7e
downloadaur-e2b06fa83044b6fc1372f97a43aee00ca44d2dcc.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
-rw-r--r--gog-baldurs-gate-enhanced-edition4
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5bebd6a97194
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gog-baldurs-gate-enhanced-edition
+ pkgdesc = Chaos threatens to overwhelm the Sword Coast. GOG Version. Linux native.
+ pkgver = 1.0.0.1
+ pkgrel = 1
+ url = http://www.gog.com/game/baldurs_gate_enhanced_edition
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = local://gog_baldurs_gate_enhanced_edition_1.0.0.1.tar.gz
+ source = gog-baldurs-gate-enhanced-edition
+ sha256sums = 8f28cded9f33543827daaa1703f05ffbcc5fe44f4f2f7e161c656fa5672ee411
+ sha256sums = e0fd7ba999325b6c085257ffce97f2f6af4df4d99d0a587f437f8aa37a9b1889
+ depends_i686 = glibc
+ depends_i686 = alsa-lib
+ depends_i686 = libgl
+ optdepends_i686 = libpulse: pulseaudio support
+ depends_x86_64 = lib32-glibc
+ depends_x86_64 = lib32-alsa-lib
+ depends_x86_64 = lib32-libgl
+ optdepends_x86_64 = lib32-libpulse: pulseaudio support
+
+pkgname = gog-baldurs-gate-enhanced-edition
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..394eab9efe20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Philippe Cherel <philippe dot cherel at mayenne dot org>
+pkgname=gog-baldurs-gate-enhanced-edition
+_pkgname=baldurs-gate-enhanced-edition
+_original="Baldurs Gate Enhanced Edition"
+pkgver=1.0.0.1
+pkgrel=1
+pkgdesc="Chaos threatens to overwhelm the Sword Coast. GOG Version. Linux native."
+arch=('i686' 'x86_64')
+url="http://www.gog.com/game/baldurs_gate_enhanced_edition"
+license=('custom')
+depends_i686=('glibc' 'alsa-lib' 'libgl')
+depends_x86_64=('lib32-glibc' 'lib32-alsa-lib' 'lib32-libgl')
+optdepends_i686=('libpulse: pulseaudio support')
+optdepends_x86_64=('lib32-libpulse: pulseaudio support')
+source=("local://gog_baldurs_gate_enhanced_edition_${pkgver}.tar.gz"
+ "${pkgname}")
+PKGEXT=".pkg.tar"
+sha256sums=('8f28cded9f33543827daaa1703f05ffbcc5fe44f4f2f7e161c656fa5672ee411'
+ 'e0fd7ba999325b6c085257ffce97f2f6af4df4d99d0a587f437f8aa37a9b1889')
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/${_pkgname}
+ cp -r "${srcdir}"/"${_original}"/* "${pkgdir}"/opt/gog/${_pkgname}
+ install -Dm644 "${srcdir}"/"${_original}"/support/${pkgname}-primary.desktop "${pkgdir}"/usr/share/applications/${pkgname}-primary.desktop
+ install -Dm644 "${srcdir}"/"${_original}"/support/${pkgname}.png "${pkgdir}"/usr/share/pixmaps/${pkgname}.png
+ install -Dm644 "${srcdir}"/"${_original}"/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}"/$pkgname "${pkgdir}"/usr/bin/${pkgname}
+}
diff --git a/gog-baldurs-gate-enhanced-edition b/gog-baldurs-gate-enhanced-edition
new file mode 100644
index 000000000000..067ed2d247ec
--- /dev/null
+++ b/gog-baldurs-gate-enhanced-edition
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+gogdir="/opt/gog/baldurs-gate-enhanced-edition"
+"${gogdir}"/start.sh