summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordoragasu2021-09-05 16:25:08 +0200
committerdoragasu2021-09-05 16:25:08 +0200
commite2b48a528e4cfad00aa3108c8fe70977e7c028cf (patch)
treec4617bbcbd6ef453d724338ab5a4e05e9faa39c9
parent115018bab295b829439877711282a6ec7a01664c (diff)
downloadaur-e2b48a528e4cfad00aa3108c8fe70977e7c028cf.tar.gz
Fix build errors and update p7zip to v17.04
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
-rw-r--r--fix_build_errs.patch23
3 files changed, 47 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4448ef40447..2359b2a67782 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib7zip
pkgdesc = A library using 7z.dll/7z.so(from 7-Zip) to handle different archive types.
- pkgver = 3.0.0
+ pkgver = 3.0.0_17.04
pkgrel = 1
url = https://github.com/stonewell/lib7zip
arch = i686
@@ -8,10 +8,11 @@ pkgbase = lib7zip
license = MPL
makedepends = libtool
options = !libtool
- source = https://github.com/stonewell/lib7zip/archive/3.0.0.tar.gz
- source = http://downloads.sourceforge.net/project/p7zip/p7zip/16.02/p7zip_16.02_src_all.tar.bz2
- sha256sums = 75def3c6393ff4eb390ed5b82f89edc1b93fd1ac92680556a8d9a4e5cad7257c
- sha256sums = 5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f
+ source = git+https://github.com/stonewell/lib7zip.git
+ source = git+https://github.com/jinfeihan57/p7zip/#tag=v17.04
+ source = fix_build_errs.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 4c3f39beea4142283d76c2652d01ceaa647717d72359f75b9e7164082ba3a12d
pkgname = lib7zip
-
diff --git a/PKGBUILD b/PKGBUILD
index 8f385a8daf75..dc376d58df39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
# Original submitter: speps <speps at aur dot archlinux dot org>
_pkg=p7zip
-_ver=16.02
+_commit=53abfeb6f1919fce3e65f21e37340153d2e4fe10
+_ver=17.04
pkgname=lib7zip
-pkgver=3.0.0
+pkgver=3.0.0_${_ver}
pkgrel=1
pkgdesc="A library using 7z.dll/7z.so(from 7-Zip) to handle different archive types."
arch=(i686 x86_64)
@@ -12,16 +13,20 @@ url="https://github.com/stonewell/lib7zip"
license=('MPL')
makedepends=('libtool')
options=('!libtool')
-source=("https://github.com/stonewell/${pkgname}/archive/${pkgver}.tar.gz"
- "http://downloads.sourceforge.net/project/${_pkg}/${_pkg}/${_ver}/${_pkg}_${_ver}_src_all.tar.bz2")
-sha256sums=('75def3c6393ff4eb390ed5b82f89edc1b93fd1ac92680556a8d9a4e5cad7257c'
- '5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f')
+source=("git+https://github.com/stonewell/${pkgname}.git"
+ "git+https://github.com/jinfeihan57/${_pkg}/#tag=v${_ver}"
+ "fix_build_errs.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ '4c3f39beea4142283d76c2652d01ceaa647717d72359f75b9e7164082ba3a12d')
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}"
+ git checkout ${_commit}
+ patch -p1 < ../fix_build_errs.patch
# point to p7zip source
- export P7ZIP_SOURCE_DIR="$srcdir/${_pkg}_${_ver}"
+ export P7ZIP_SOURCE_DIR="${srcdir}/${_pkg}"
cmake -DBUILD_SHARED_LIB=ON \
-DP7ZIP_SOURCE_DIR=${P7ZIP_SOURCE_DIR} \
@@ -29,14 +34,14 @@ prepare() {
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}"
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver/src"
+ cd "${srcdir}/${pkgname}/src"
# Provided CMakeLists does not install files, so install manually
- install -Dm755 $pkgname.so $pkgdir/usr/lib/${pkgname}.so
- install -Dm644 $pkgname.h $pkgdir/usr/include/${pkgname}.h
+ install -Dm755 ${pkgname}.so ${pkgdir}/usr/lib/${pkgname}.so
+ install -Dm644 ${pkgname}.h ${pkgdir}/usr/include/${pkgname}.h
}
diff --git a/fix_build_errs.patch b/fix_build_errs.patch
new file mode 100644
index 000000000000..48562cfe84aa
--- /dev/null
+++ b/fix_build_errs.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8d28c09..bc72155 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -39,7 +39,7 @@ SET(P7ZIP_INCLUDE_PATH "${P7ZIP_SOURCE_DIR}"
+
+
+ if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
+- set(warnings -Wall -Wextra -Werror -Wno-unused-parameter)
++ set(warnings -Wall -Wextra -Werror -Wno-unused-parameter -Wno-misleading-indentation)
+ set(cxx_warnings -Wno-class-memaccess)
+ set(no_undefined -Wl,--no-undefined)
+ elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 3863b34..d69806b 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -38,4 +38,5 @@ SET_TARGET_PROPERTIES(lib7zip_shared PROPERTIES LINKER_LANGUAGE CXX)
+ TARGET_INCLUDE_DIRECTORIES(lib7zip_shared PRIVATE
+ "${P7ZIP_INCLUDE_PATH}"
+ )
++TARGET_LINK_LIBRARIES(lib7zip_shared dl)
+ ENDIF()