summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPol Marcet Sardà2019-01-17 22:58:45 +0100
committerPol Marcet Sardà2019-01-17 22:58:45 +0100
commite2bddf7c7063c25e1d01fd68bdce7dc69eaf5138 (patch)
tree52b97fe7a60746f70cba8ac75edddcf770353517
parentd4f7f177dc7b5648a41f56d2d561d21d3a587649 (diff)
downloadaur-e2bddf7c7063c25e1d01fd68bdce7dc69eaf5138.tar.gz
Usual update and updated patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--arch.patch39
3 files changed, 33 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48fa12e9e0cb..6b4ffa2d6205 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = k8vavoom-git
pkgdesc = Source port of Doom
- pkgver = r7417.023db7608
+ pkgver = r7733.e62fbc9da
pkgrel = 1
url = https://repo.or.cz/k8vavoom.git
arch = x86_64
@@ -15,10 +15,10 @@ pkgbase = k8vavoom-git
depends = sdl2_mixer
depends = openal
optdepends = libmad
- source = k8vavoom-git::git+https://repo.or.cz/k8vavoom.git#commit=023db7608919f8e9da345e2fa4c93d712010c86e
+ source = k8vavoom-git::git+https://repo.or.cz/k8vavoom.git#commit=e62fbc9dab064c4a3ac2e0fbb172cf252ef7bd90
source = arch.patch
sha256sums = SKIP
- sha256sums = b35e882aee67e17a0a4bc2654fb15e8b014d69d666d138408375d8171250f192
+ sha256sums = 29177e8444ef45c5ec61599b6be158fb5c06ab1fd36558c1d4f25fe9ee1a37c8
pkgname = k8vavoom-git
diff --git a/PKGBUILD b/PKGBUILD
index b3896e428d49..27d069e51c37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer Pol Marcet Sardà <polmarcetsarda@gmail.com>
pkgname=k8vavoom-git
-pkgver=r7417.023db7608
+pkgver=r7733.e62fbc9da
pkgrel=1
pkgdesc="Source port of Doom"
arch=(x86_64)
@@ -12,11 +12,11 @@ depends=("zlib" "bzip2" "libpng" "libjpeg" "sdl2" "sdl2_mixer" "openal")
makedepends=("cmake" "git")
optdepends=("libmad")
-source=("$pkgname"::"git+https://repo.or.cz/k8vavoom.git#commit=023db7608919f8e9da345e2fa4c93d712010c86e"
+source=("$pkgname"::"git+https://repo.or.cz/k8vavoom.git#commit=e62fbc9dab064c4a3ac2e0fbb172cf252ef7bd90"
"arch.patch")
sha256sums=('SKIP'
- 'b35e882aee67e17a0a4bc2654fb15e8b014d69d666d138408375d8171250f192')
+ '29177e8444ef45c5ec61599b6be158fb5c06ab1fd36558c1d4f25fe9ee1a37c8')
pkgver() {
cd "$pkgname"
@@ -33,7 +33,7 @@ build() {
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_MASTER=ON \
- -DENABLE_SERVER=ON \
+ -DENABLE_SERVER=OFF \
-DENABLE_VCCRUN=ON \
-DWITH_SYS_LIBPNG=ON \
.
diff --git a/arch.patch b/arch.patch
index 721252fbd0e0..66977a932af8 100644
--- a/arch.patch
+++ b/arch.patch
@@ -1,8 +1,8 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 5cfbeef1a..f0cf9a33b 100644
+index c99a6c7af..352d72f24 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -102,7 +102,7 @@ if(NOT CMAKE_BUILD_TYPE)
+@@ -99,7 +99,7 @@ if(NOT CMAKE_BUILD_TYPE)
endif()
@@ -12,11 +12,11 @@ index 5cfbeef1a..f0cf9a33b 100644
set(UNFUCK_GCC_FLAGS "")
set(UNFUCK_GXX_FLAGS "")
diff --git a/source/in_sdl.cpp b/source/in_sdl.cpp
-index 3c0787a65..9a3e1744b 100644
+index c0024a8ed..363db9197 100644
--- a/source/in_sdl.cpp
+++ b/source/in_sdl.cpp
-@@ -22,7 +22,7 @@
- //** GNU General Public License for more details.
+@@ -24,7 +24,7 @@
+ //** along with this program. If not, see <http://www.gnu.org/licenses/>.
//**
//**************************************************************************
-#include <SDL.h>
@@ -24,12 +24,25 @@ index 3c0787a65..9a3e1744b 100644
#include "gamedefs.h"
#include "drawer.h"
#include "ui/ui.h"
+diff --git a/source/neoui/neoui_main.cpp b/source/neoui/neoui_main.cpp
+index d7aa78e37..bcd1e77cd 100644
+--- a/source/neoui/neoui_main.cpp
++++ b/source/neoui/neoui_main.cpp
+@@ -26,7 +26,7 @@
+ #include "../gamedefs.h"
+
+ #ifdef CLIENT
+-#include <SDL.h>
++#include <SDL2/SDL.h>
+ #ifdef USE_GLAD
+ # include "glad.h"
+ #else
diff --git a/source/render/hwgl/gl_sdl.cpp b/source/render/hwgl/gl_sdl.cpp
-index c1067f64d..03d4d8884 100644
+index 6d1993889..bdf9f9585 100644
--- a/source/render/hwgl/gl_sdl.cpp
+++ b/source/render/hwgl/gl_sdl.cpp
-@@ -22,7 +22,7 @@
- //** GNU General Public License for more details.
+@@ -24,7 +24,7 @@
+ //** along with this program. If not, see <http://www.gnu.org/licenses/>.
//**
//**************************************************************************
-#include <SDL.h>
@@ -38,10 +51,10 @@ index c1067f64d..03d4d8884 100644
diff --git a/source/sys_sdl.cpp b/source/sys_sdl.cpp
-index f0be647bc..d63078b62 100644
+index b737bab95..ed9f1f6d3 100644
--- a/source/sys_sdl.cpp
+++ b/source/sys_sdl.cpp
-@@ -30,7 +30,7 @@
+@@ -31,7 +31,7 @@
#include <unistd.h>
#include <signal.h>
#include <dirent.h>
@@ -51,10 +64,10 @@ index f0be647bc..d63078b62 100644
# include <execinfo.h>
#elif defined(__SWITCH__)
diff --git a/vccrun/modules/sdlgl/mod_sdlgl.cpp b/vccrun/modules/sdlgl/mod_sdlgl.cpp
-index c805a6192..aa1992f7b 100644
+index b648891c5..f5dc0db52 100644
--- a/vccrun/modules/sdlgl/mod_sdlgl.cpp
+++ b/vccrun/modules/sdlgl/mod_sdlgl.cpp
-@@ -32,7 +32,7 @@
+@@ -34,7 +34,7 @@
#include <sys/time.h>
@@ -64,7 +77,7 @@ index c805a6192..aa1992f7b 100644
#include <GL/glext.h>
static SDL_Window *hw_window = nullptr;
diff --git a/vccrun/modules/sdlgl/mod_sdlgl.h b/vccrun/modules/sdlgl/mod_sdlgl.h
-index 82589ae04..d9aca8540 100644
+index 24b769202..d779a01c9 100644
--- a/vccrun/modules/sdlgl/mod_sdlgl.h
+++ b/vccrun/modules/sdlgl/mod_sdlgl.h
@@ -30,7 +30,7 @@