summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Damhet2017-08-26 17:55:20 +0200
committerAntoine Damhet2017-08-26 17:55:20 +0200
commite2cdbd9d23fef1c974bf7e269f92750e137daf51 (patch)
tree7d06ca6892c0159d0b1720589554df10da8de23c
downloadaur-e2cdbd9d23fef1c974bf7e269f92750e137daf51.tar.gz
initial commit for 1.0
Signed-off-by: Antoine Damhet <antoine.damhet@lse.epita.fr>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..449577d2511a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mkinitcpio-gnupg
+ pkgdesc = mkinitcpio hook that adds GnuPG and smartcard support
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/xdbob/mkinitcpio-gnupg
+ arch = any
+ depends = gnupg
+ depends = pinentry
+ depends = pcsclite
+ optdepends = libusb-compat: Allows the use of USB smartcard like YubiKey
+ source = https://github.com/xdbob/mkinitcpio-gnupg/archive/v1.0.tar.gz
+ sha256sums = 7e65320dfc84caf2e3ae30ad5fcee0b2cd50faaf62bb5d5818a269186919c9b0
+
+pkgname = mkinitcpio-gnupg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89cf5d294611
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Antoine Damhet <antoine.damhet@lse.epita.fr>
+pkgname=mkinitcpio-gnupg
+pkgdesc="mkinitcpio hook that adds GnuPG and smartcard support"
+pkgver=1.0
+pkgrel=1
+arch=(any)
+depends=(gnupg pinentry pcsclite)
+optdepends=('libusb-compat: Allows the use of USB smartcard like YubiKey')
+url="https://github.com/xdbob/mkinitcpio-gnupg"
+source=(https://github.com/xdbob/$pkgname/archive/v$pkgver.tar.gz)
+licence=('GPL')
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -D -m0644 "gnupg-hook" "${pkgdir}/usr/lib/initcpio/hooks/gnupg"
+ install -D -m0644 "gnupg-install" "${pkgdir}/usr/lib/initcpio/install/gnupg"
+}
+
+sha256sums=('7e65320dfc84caf2e3ae30ad5fcee0b2cd50faaf62bb5d5818a269186919c9b0')