summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-11-28 12:32:05 -0700
committerMark Wagie2023-11-28 12:32:05 -0700
commite2dd80b4a089370896a046c274d2cbfceb372d92 (patch)
tree4d59c71f1a1123d6d4fc398f9063a7bea6746872
parent1d4198cdab02ecff71d8b201ade0199d40c0b3b4 (diff)
downloadaur-e2dd80b4a089370896a046c274d2cbfceb372d92.tar.gz
20.04.83
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD47
2 files changed, 38 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af8bfd8bea30..eaca1358ebe8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-driver
pkgdesc = Universal driver for System76 computers
- pkgver = 20.04.82
+ pkgver = 20.04.83
pkgrel = 1
url = https://github.com/pop-os/system76-driver
install = system76-driver.install
@@ -16,10 +16,10 @@ pkgbase = system76-driver
depends = dmidecode
depends = ethtool
depends = gtk3
+ depends = libnotify
depends = lm_sensors
depends = pciutils
depends = polkit
- depends = python
depends = python-cffi
depends = python-dbus
depends = python-distro
@@ -33,7 +33,6 @@ pkgbase = system76-driver
depends = wireless_tools
optdepends = firmware-manager: Manage System76 firmware updates via standalone application
optdepends = grub: Required to apply kernel parameters
- optdepends = pm-utils: For power management features
optdepends = pulseaudio: To apply microphone fix
optdepends = system76-dkms: Control hotkeys and fan on certain System76 laptops
optdepends = system76-acpi-dkms: Provides the system76_acpi in-tree driver (only for (<5.16)
@@ -42,7 +41,7 @@ pkgbase = system76-driver
optdepends = system76-power: System76 Power Management
optdepends = xorg-xhost: To enable GUI applications on Wayland
optdepends = xorg-xbacklight: To use the backlight service
- source = git+https://github.com/pop-os/system76-driver.git#commit=dfbce5baac1900ab82138a3b55947b3816d6f181
+ source = git+https://github.com/pop-os/system76-driver.git#commit=be90e3f4b4ebbc557962edd429edfdd78d21101d
source = cli.patch
source = wayland.patch
source = actions.patch
diff --git a/PKGBUILD b/PKGBUILD
index 4e4fa3fc5442..65bcf52ed9aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,44 @@
# Contributor: ava1ar <mail(at)ava1ar(dot)me>
# Contributor: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=system76-driver
-pkgver=20.04.82
+pkgver=20.04.83
pkgrel=1
pkgdesc="Universal driver for System76 computers"
arch=('any')
url="https://github.com/pop-os/system76-driver"
license=('GPL')
-depends=('at' 'dmidecode' 'ethtool' 'gtk3' 'lm_sensors' 'pciutils' 'polkit'
- 'python' 'python-cffi' 'python-dbus' 'python-distro' 'python-evdev'
- 'python-gobject' 'python-pynacl' 'python-systemd' 'python-xlib'
- 'system76-firmware-daemon' 'usbutils' 'wireless_tools')
-makedepends=('git' 'python-build' 'python-installer' 'python-pyflakes'
- 'python-setuptools' 'python-wheel')
+depends=(
+ 'at'
+ 'dmidecode'
+ 'ethtool'
+ 'gtk3'
+ 'libnotify'
+ 'lm_sensors'
+ 'pciutils'
+ 'polkit'
+ 'python-cffi'
+ 'python-dbus'
+ 'python-distro'
+ 'python-evdev'
+ 'python-gobject'
+ 'python-pynacl'
+ 'python-systemd'
+ 'python-xlib'
+ 'system76-firmware-daemon'
+ 'usbutils'
+ 'wireless_tools'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-pyflakes'
+ 'python-setuptools'
+ 'python-wheel'
+)
optdepends=(
'firmware-manager: Manage System76 firmware updates via standalone application'
'grub: Required to apply kernel parameters'
- 'pm-utils: For power management features'
'pulseaudio: To apply microphone fix'
'system76-dkms: Control hotkeys and fan on certain System76 laptops'
'system76-acpi-dkms: Provides the system76_acpi in-tree driver (only for (<5.16)'
@@ -25,9 +47,10 @@ optdepends=(
'system76-oled: Control brightness on OLED displays'
'system76-power: System76 Power Management'
'xorg-xhost: To enable GUI applications on Wayland'
- 'xorg-xbacklight: To use the backlight service')
+ 'xorg-xbacklight: To use the backlight service'
+)
install="$pkgname.install"
-_commit=dfbce5baac1900ab82138a3b55947b3816d6f181 # tags/20.04.82^0
+_commit=be90e3f4b4ebbc557962edd429edfdd78d21101d # tags/20.04.83^0
source=(
"git+https://github.com/pop-os/system76-driver.git#commit=${_commit}"
'cli.patch'
@@ -75,7 +98,7 @@ package() {
python -m installer --destdir="$pkgdir" dist/*.whl
# Install daemons and executables
- install -Dm755 system76-daemon system76-user-daemon -t "$pkgdir/usr/lib/$pkgname/"
+ install -Dm755 system76-{daemon,user-daemon} -t "$pkgdir/usr/lib/$pkgname/"
install -Dm755 "$pkgname-pkexec" -t "$pkgdir/usr/bin/"
# Install systemd unit files
@@ -90,7 +113,7 @@ package() {
# "$pkgdir/usr/lib/systemd/system-sleep/"
# Install scripts and configuration
- install -m755 system76-nm-restart system76-thunderbolt-reload "$pkgdir/usr/lib/$pkgname/"
+ install -m755 system76-{nm-restart,thunderbolt-reload} "$pkgdir/usr/lib/$pkgname/"
install -Dm644 "com.system76.pkexec.$pkgname.policy" -t \
"$pkgdir/usr/share/polkit-1/actions/"