summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerber2016-01-02 15:56:23 +0100
committerMichael Gerber2016-01-02 15:56:23 +0100
commite2dece7eba0f0ea7a9695a6cd93ea86ee74a1ee5 (patch)
treeb5b2b2eac98dbd40299721745ccd90b02be2a9b1
downloadaur-e2dece7eba0f0ea7a9695a6cd93ea86ee74a1ee5.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--open-xchange-system.install14
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc25288a1d31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Jan 2 14:56:23 UTC 2016
+pkgbase = open-xchange-system
+ pkgdesc = system integration specific infrastructure
+ pkgver = 7.8.0
+ pkgrel = 6
+ url = http://www.ox.io/
+ install = open-xchange-system.install
+ arch = any
+ groups = open-xchange-minimal
+ license = GPLv2
+ provides = open-xchange-system
+ source = https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-system_7.8.0-6_all.deb
+ sha256sums = a347953370f8452fb436d591cf58ec634bcad0e10de0d3feeeaf076d08faeb0d
+
+pkgname = open-xchange-system
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43ae3e42d5e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-system
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='system integration specific infrastructure'
+groups=('open-xchange-minimal')
+install='open-xchange-system.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=()
+makedepends=()
+conflicts=()
+provides=('open-xchange-system')
+source=('https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-system_7.8.0-6_all.deb')
+sha256sums=('a347953370f8452fb436d591cf58ec634bcad0e10de0d3feeeaf076d08faeb0d')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}
diff --git a/open-xchange-system.install b/open-xchange-system.install
new file mode 100644
index 000000000000..27ab8bbd33a0
--- /dev/null
+++ b/open-xchange-system.install
@@ -0,0 +1,14 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+pre_install() {
+ if ! id -u "open-xchange" >/dev/null 2>&1; then
+ echo "user open-xchange does not exist. Creating it now"
+ useradd -U -s /usr/bin/false -d /opt/open-xchange open-xchange
+ fi
+}
+
+post_install() {
+ chown -R open-xchange:open-xchange /opt/open-xchange
+}