summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiancarlo Razzolini2017-03-07 14:56:50 -0300
committerGiancarlo Razzolini2017-03-07 14:56:50 -0300
commite2dfb5fd7e56d2e3e7c170ad157743f453686ef2 (patch)
tree3c38631ba052161e5c355acb9f1295cb7e4c5c4e
parent7a6465317e49e8d36040d799018d0573ffa02fe1 (diff)
downloadaur-e2dfb5fd7e56d2e3e7c170ad157743f453686ef2.tar.gz
updpkg: Version 0.9.1
Change the build process to not use the binary blob anymore and actually build the plugin. This requires new makedepends and some more time to create the package.
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 29 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c53a2387ea9..e18a42d90f47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
# Generated by mksrcinfo v8
-# Mon Feb 20 23:07:04 UTC 2017
+# Tue Mar 7 17:56:45 UTC 2017
pkgbase = keepass-plugin-keeagent-beta
pkgdesc = SSH Agent Plugin for KeePass - Beta Version
- pkgver = 0.9.0
+ pkgver = 0.9.1
pkgrel = 1
url = http://lechnology.com/software/keeagent/
- install = keepass-plugin-keeagent-beta.install
arch = any
license = GPL
+ makedepends = git
+ makedepends = nuget
depends = keepass
optdepends = openssh: For integration with ssh-agent
optdepends = gnupg: For integration with GnuPG SSH agent
provides = keepass-plugin-keeagent
conflicts = keepass-plugin-keeagent
- source = keepass-plugin-keeagent-beta-0.9.0.zip::http://lechnology.com/wp-content/uploads/2017/01/KeeAgent_Beta_v0.9.0.zip
- sha512sums = a7f41fb3867d474b0c4b3d2f9d58e05c783006c4a41ac148b77d55837ab9349de16c62e30455affd9a95ad5729b20388998e17964f950713bcf9d93fe5ff1299
+ source = keepass-plugin-keeagent-beta-0.9.1::git+https://github.com/dlech/KeeAgent.git#tag=v0.9.1
+ sha512sums = SKIP
pkgname = keepass-plugin-keeagent-beta
diff --git a/.gitignore b/.gitignore
index 127c7db0d5c4..057bc078f137 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
keepass-plugin-keeagent-*.pkg.tar.xz
keepass-plugin-keeagent-*.src.tar.gz
KeeAgent_*.zip
-keepass-plugin-keeagent-*.zip \ No newline at end of file
+keepass-plugin-keeagent-*.zip
+pkg/*
+src/*
diff --git a/PKGBUILD b/PKGBUILD
index 513b01f027af..dfd448cfca56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,37 @@
# Maintainer: Giancarlo Razzolinit <grazzolini@gmail.com>
pkgname=keepass-plugin-keeagent-beta
-pkgver=0.9.0
+pkgver=0.9.1
pkgrel=1
pkgdesc="SSH Agent Plugin for KeePass - Beta Version"
license=('GPL')
+makedepends=('git' 'nuget')
depends=('keepass')
optdepends=('openssh: For integration with ssh-agent' 'gnupg: For integration with GnuPG SSH agent')
provides=('keepass-plugin-keeagent')
conflicts=('keepass-plugin-keeagent')
arch=('any')
url="http://lechnology.com/software/keeagent/"
-DLAGENTS='http::/usr/bin/curl -fLC - --user-agent Firefox --retry 3 --retry-delay 3 -o %o %u'
-install=$pkgname.install
-source=("${pkgname}-${pkgver}.zip::http://lechnology.com/wp-content/uploads/2017/01/KeeAgent_Beta_v0.9.0.zip")
-sha512sums=('a7f41fb3867d474b0c4b3d2f9d58e05c783006c4a41ac148b77d55837ab9349de16c62e30455affd9a95ad5729b20388998e17964f950713bcf9d93fe5ff1299')
+source=("${pkgname}-${pkgver}::git+https://github.com/dlech/KeeAgent.git#tag=v${pkgver}")
+sha512sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ git submodule update --init --recursive
+
+ nuget restore
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ xbuild /property:Configuration=ReleasePlgx KeeAgent.sln
+}
package() {
- install -Dm644 KeeAgent.plgx -t "$pkgdir/usr/share/keepass/plugins/"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm644 KeeAgent/bin/ReleasePlgx/KeeAgent.plgx -t "$pkgdir/usr/share/keepass/plugins/"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 GPL2.txt "$pkgdir/usr/share/licenses/$pkgname/GPL2.txt"
- cp -r SshAgentLib.License "${pkgdir}/usr/share/licenses/$pkgname/"
}