summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 17:07:04 +0800
committerSainnhepark2020-10-23 17:07:04 +0800
commite31fed3dd3fde7d7ae8e4ec05e0053fef9f1834a (patch)
tree39a9d5e06bdd2bd1b98a925345cc533a268831b0
parent4c55522759f7d12213e01c6863322e6b2e092f14 (diff)
downloadaur-e31fed3dd3fde7d7ae8e4ec05e0053fef9f1834a.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 010c7536b871..96636b28cd3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = neovim-coc-yank-git
url = https://github.com/neoclide/coc-yank
arch = any
groups = neovim-coc-extras-git
- license =
+ license = MIT
makedepends = git
makedepends = yarn
makedepends = npm
diff --git a/PKGBUILD b/PKGBUILD
index b7b1d3d9745c..e48d0c84cb6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url='https://github.com/neoclide/coc-yank'
depends=('neovim-coc')
makedepends=('git' 'yarn' 'npm')
_packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
-license=('')
+license=('MIT')
groups=('neovim-coc-extras-git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}