summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBradford Smith2023-01-03 17:54:39 -0500
committerBradford Smith2023-01-03 17:54:39 -0500
commite34e0956885795a56afd68ca506bf7ea49eae4a2 (patch)
treead0f3dabe0ddad7d04b88c39be68a7f20b6623c9
parent3cd3dfcacb8674f026acade535632cec9408a720 (diff)
downloadaur-e34e0956885795a56afd68ca506bf7ea49eae4a2.tar.gz
Add python-setuptools as makedepends
This package is required to build informant, it was an error that it was left out because it's installed as a full dependency for other things on my system.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD1
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index baa1f9a4f150..ece346e46f90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = informant
install = informant.install
arch = any
license = MIT
+ makedepends = python-setuptools
depends = python
depends = python-docopt
depends = python-dateutil
@@ -15,6 +16,6 @@ pkgbase = informant
depends = python-lockfile
options = zipman
source = https://github.com/bradford-smith94/informant/archive/v0.4.5.tar.gz
- sha256sums = 4f8745bec30fb82396b141f99a529d542085bcda982a9d178ebba5c07fd4425f
+ sha256sums = b82d6accae509bcda3fc4a02b849e9093cbc18f0f728422f27570539c9c53751
pkgname = informant
diff --git a/PKGBUILD b/PKGBUILD
index 1a2378d506ee..203f71b399dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ arch=('any')
url="https://github.com/bradford-smith94/$pkgname"
license=('MIT')
install=informant.install
+makedepends=('python-setuptools')
depends=('python' 'python-docopt' 'python-dateutil' 'python-feedparser' 'python-html2text' 'python-cachecontrol' 'python-lockfile')
source=("https://github.com/bradford-smith94/$pkgname/archive/v$pkgver.tar.gz")
options=(zipman)