summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Seleznev2018-04-11 16:49:57 +0300
committerRoman Seleznev2018-04-11 16:49:57 +0300
commite35c547007ebaff02caecea388a7060720202a41 (patch)
tree2a50b56c3d4b3b9f2be79e7d6d554dc2c59d4cc5
downloadaur-e35c547007ebaff02caecea388a7060720202a41.tar.gz
Init commit for package. Version 7.2-106
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
-rw-r--r--aps.ini1
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e7a118a1bd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = aps-php-runtime
+ pkgdesc = Parallels APS PHP Runtime
+ pkgver = 7.2
+ pkgrel = 1
+ url = https://doc.apsstandard.org/7.3/resources/tools/php-lib/#php-runtime
+ arch = any
+ license = custom
+ depends = php>=7.2
+ provides = aps-php-runtime
+ conflicts = aps-php-runtime
+ replaces = aps-php-runtime
+ source = http://download.apsstandard.org/php.runtime/aps-php-runtime-7.2-106.zip
+ md5sums = 068e7ee0cc6d1f31b870f087e0c04227
+
+pkgname = aps-php-runtime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..956fc97e188e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Roman Seleznev <alone.inbox@gmail.com>
+# This PKGBUILD is maintained at https://github.com/TechCatOther/aur-packages
+
+
+pkgbase=aps-php-runtime
+pkgname=('aps-php-runtime')
+pkgdesc='Parallels APS PHP Runtime'
+pkgver=7.2
+subversion=106
+pkgrel=1
+arch=('any')
+url='https://doc.apsstandard.org/7.3/resources/tools/php-lib/#php-runtime'
+license=('custom')
+replaces=('aps-php-runtime')
+conflicts=('aps-php-runtime')
+provides=('aps-php-runtime')
+depends=('php>=7.2')
+optdepends=()
+makedepends=()
+
+source=("http://download.apsstandard.org/php.runtime/aps-php-runtime-${pkgver}-${subversion}.zip")
+md5sums=(068e7ee0cc6d1f31b870f087e0c04227)
+
+prepare() {
+ echo 'indule_path = ${include_path}:/usr/share/aps/php' > ${srcdir}/aps.ini
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/aps/php/aps/2/{formats,types}
+ install -D -m644 -t ${pkgdir}/usr/share/aps/php/aps/2/ ${srcdir}/aps/2/*.php
+ install -D -m644 -t ${pkgdir}/usr/share/aps/php/aps/2/formats/ ${srcdir}/aps/2/formats/*.php
+ install -D -m644 -t ${pkgdir}/usr/share/aps/php/aps/2/types/ ${srcdir}/aps/2/types/*.php
+ install -D -m644 -t ${pkgdir}/etc/php/conf.d/ ${srcdir}/aps.ini
+}
+
+# vim:set ts=4 sw=4 et:
+
diff --git a/aps.ini b/aps.ini
new file mode 100644
index 000000000000..6b38370a8a6e
--- /dev/null
+++ b/aps.ini
@@ -0,0 +1 @@
+indule_path = ${include_path}:/usr/share/aps/php