summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2021-06-19 15:56:08 +0000
committerGitHub Action2021-06-19 15:56:08 +0000
commite37534e1348e0ceb2dc85f18def11117bc1292e9 (patch)
tree322d2427f20703767374890276a7adfdab51f29e
parentb42eaf34acd17439063946f9dac2a173a2169ce1 (diff)
downloadaur-e37534e1348e0ceb2dc85f18def11117bc1292e9.tar.gz
Update from GitHub Actions: nodejs-cmake-js: update to 6.1.0-2
https://github.com/ouuan/AUR-packages/actions/runs/952736576
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD35
2 files changed, 22 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3417b3aafe64..2af88c0b8788 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = nodejs-cmake-js
- pkgdesc = A fast, simple & powerful blog framework, powered by Node.js.
+ pkgdesc = CMake.js - a Node.js native addon build tool
pkgver = 6.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cmake-js/cmake-js
arch = any
license = MIT
makedepends = npm
depends = nodejs
depends = cmake
- noextract = ${pkgver}.tar.gz
+ noextract = nodejs-cmake-js-6.1.0.tgz
options = !strip
- source = https://github.com/cmake-js/cmake-js/archive/v6.1.0.tar.gz
- sha256sums = bb0defbf3f0492f8bbeaed8cd01d08d5b431a23e0ea79afe890cc4beec2536d2
+ source = https://registry.npmjs.org/cmake-js/-/cmake-js-6.1.0.tgz
+ sha256sums = 2e6f50acd31e38493e5047174f8de0398fc4157d7b861f00f81a48d41fd91349
pkgname = nodejs-cmake-js
-
diff --git a/PKGBUILD b/PKGBUILD
index 99d49b94f4eb..cbf46ba4355d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
-_name="cmake-js"
-pkgname="nodejs-${_name}"
-pkgver="6.1.0"
-pkgrel="1"
-pkgdesc="A fast, simple & powerful blog framework, powered by Node.js."
+# Maintainer: Yufan You <ouuansteve at gmail>
+
+_npmname=cmake-js
+pkgname=nodejs-cmake-js
+pkgver=6.1.0
+pkgrel=2
+pkgdesc="CMake.js - a Node.js native addon build tool"
arch=('any')
url="https://github.com/cmake-js/cmake-js"
license=('MIT')
depends=('nodejs' 'cmake')
makedepends=('npm')
options=(!strip)
-source=("https://github.com/cmake-js/cmake-js/archive/v${pkgver}.tar.gz")
-sha256sums=('bb0defbf3f0492f8bbeaed8cd01d08d5b431a23e0ea79afe890cc4beec2536d2')
-
-# Don't extract package
-noextract=('${pkgver}.tar.gz')
+source=("https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
+sha256sums=('2e6f50acd31e38493e5047174f8de0398fc4157d7b861f00f81a48d41fd91349')
+noextract=("${pkgname}-${pkgver}.tgz")
package() {
- local _npmdir="${pkgdir}/usr/lib/node_modules/"
- install -dm755 "${_npmdir}"
- cd "${_npmdir}"
- npm install --user root -g --prefix "${pkgdir}/usr" ${_name}@${pkgver}
-
- # License
- cd "${_npmdir}/cmake-js"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${_name}/LICENSE"
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" "$_npmname@$pkgver"
+ install -Dm644 "$_npmdir/$_npmname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ chown -R root:root "${pkgdir}"
}